Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install deluge through synaptic package manager but I got problem:

deluge:
 Depends: python-libtorrent but it is not going to be installed

I have tried reinstall python-libtorrent by apt-get and also I got problem:

The following packages have unmet dependencies:
 python-libtorrent : Depends: libtorrent-rasterbar6 (= 0.15.7-1) but 0.15.9+svn.r6292-0ubuntu1~natty is to be installed

How actually I can install deluge? Thanks

share|improve this question
    
try this askubuntu.com/questions/140246/… –  Raja Sep 9 '12 at 12:09

1 Answer 1

up vote 1 down vote accepted

UPDATE: If the package libtorrent-rasterbar6 is already installed, try reinsalling it.

sudo apt-get install --reinstall libtorrent-rasterbar6

First install libtorrent-rasterbar6:

sudo apt-get install libtorrent-rasterbar6

Then install python-libtorrent:

sudo apt-get install python-libtorrent

And then install deluge:

sudo apt-get install deluge

Note: If you find any other dependencies at any stage, install them first.

share|improve this answer
    
libtorrent-rasterbar6 was already installed, while installing python-libtorrent i've got the same error "The following ..." –  megas Sep 9 '12 at 12:23
    
try removing libtorrent-rasterbar6 and installing again. –  green7 Sep 9 '12 at 12:27
    
It fixed the problem, thanks –  megas Sep 9 '12 at 12:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.