Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm trying to install themes with gnome tweak, and I need to install gnome-shell-extensions-user-theme because otherwise I cannot see the shell extensions tab. However, I cannot install shell extensions. I have tried to install by adding the PPA with the following:

sudo add-apt-repository ppa:webupd8team/gnome3

Then,

sudo apt-get update

Finally, when I try to install:

sudo apt-get install gnome-shell-extensions-user-theme

It gives an error:

The following packages have unmet dependencies:
gnome-shell-extensions-user-theme : Depends: gnome-shell-extensions-common but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I am convinced that there is a problem with the package. So I went on and tried to install the extensions from the website: https://extensions.gnome.org/

But even though I use Firefox (15.0), I cannot see the "switch" that is being mentioned to install the extension. Maybe the version of Firefox is too new.

Is there any workaround that you know of?

(By the way, I use Ubuntu 12.04, freshly downloaded and installed.)

share|improve this question
    
try "sudo apt-get install -f" –  Sushantp606 Nov 27 '13 at 16:52
add comment

marked as duplicate by Avinash Raj, karel, Florian Diesch, Radu Rădeanu, Eric Carvalho Dec 31 '13 at 0:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

I know it's a little late, but if you go to the Ubuntu Software Center and search for the Gnome Shell Common package (gnome-shell-common) it will install all of the common files required here.

Please note: as the source file for the user-themes extension is provided and modified by a party outside of the included source repositories for the gnome-shell installation, compatibility cannot be guaranteed.

share|improve this answer
add comment

first remove it completely by -

sudo add-apt-repository --remove ppa:webupd8team/gnome3
sudo apt-get purge gnome-shell-extensions-user-theme

Try following commands -

sudo apt-get update
sudo apt-get dist-upgrade 

Its seems the issue is your broken Downloads , so use -

sudo apt-get install -f

Then try installing gnome-shell-extensions-user-theme again

sudo add-apt-repository  ppa:webupd8team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell-extensions-user-theme

hope it will work.If it still have problems than try to install it manually as follows-

Download gnome-shell-extensions from here and then install it.

or use this one line command for installing gtk 3.8.3.10 -

cd ~ && mkdir -p .blumixinstall && cd .blumixinstall && wget https://github.com/rhoconlinux/Blumix/archive/master.zip && unzip master.zip && cd Blumix-master/ && sudo cp -a Blumix/ /usr/share/themes/ && gsettings set org.gnome.desktop.interface gtk-theme "Blumix" && gsettings set org.gnome.desktop.wm.preferences theme "Blumix" && rm -Rf ~/.blumixinstall && cd ~
share|improve this answer
add comment

After adding the PPA and then updating the repositories,run the below command,

sudo aptitude install gnome-shell-extensions-user-theme
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.