Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't add any new layout to my keyboard, the button is deactivated!

an error message raised to me to include the output of those 4 commands in the error report!

moemen@moemen:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us", "", "terminate:ctrl_alt_bksp"
moemen@moemen:~$ gsettings get org.gnome.libgnomekbd.keyboard model
''
moemen@moemen:~$ gsettings get org.gnome.libgnomekbd.keyboard layouts
@as []
moemen@moemen:~$ gsettings get org.gnome.libgnomekbd.keyboard options
@as []
share|improve this question
    
Does this help? If yes, this may be a duplicate. –  Tom Brossman Sep 9 '12 at 6:45
    
It's a different error, the solution mentioned there: the layout is empty, and has notification This key has no schema . –  Mo'men Sep 9 '12 at 7:07
add comment

1 Answer

The problem solved :)

It was just a permission issue, I get the ownership of the keyboard configuration, and it work well now :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.