Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My computer refuses to boot from the USB even after I change everything that I can possibly think of on my motherboard's BIOS.

But I have booted from the USB twice in the past. The first time is when I first got the computer and needed to install a new operating system. The second time is when I installed Windows onto the whole hard drive and needed to reinstall Ubuntu.

It seems that it only refuses to boot if there is already an existing installation of Ubuntu on the hard drive.

Any ideas on what is going on?

share|improve this question
    
try changing the usb ? us CD instead ? –  Suhaib Sep 9 '12 at 3:23
    
Have you tried the USB on a different machine? –  Mitch Sep 9 '12 at 5:40
add comment

3 Answers

Try create bootable USB with Ubuntu one more time from scratch. Sometimes it goes wrong. I'm usig UNetbootin http://unetbootin.sourceforge.net/

share|improve this answer
add comment

You may refer to this tutorial even if your BIOS won’t let you boot from USB.

Other method.

1. Live CD

To install Ubuntu on a computer that currently runs Windows, you need to download the installation file and burn it onto the CD, which you can then use to install Ubuntu. Once you’ve downloaded the file, follow the instructions below to burn your CD, depending on which version of Windows you are currently using.

You can find tutorial here.

2. Live USB

To run Ubuntu from a USB stick, the first thing you need to do is insert a USB stick with at least 2GB of free space into your PC.

The easiest way to put Ubuntu onto your stick is to use the USB installer provided at pendrivelinux.com. You’ll need to download and install and follow the instructions.

Download Pen Drive Linux's USB Installer

Tutorial here.

3. Wubi

Once the Windows installer has been downloaded, you need to open it to install Ubuntu. You’ll find detailed instructions below. If you need further help, support options are listed at the bottom of this page.

Tutorial here.

share|improve this answer
add comment

One possible solution would be to go into the BIOS settings, Boot order, and go into HDDs. In some Bios versions, there you can choose the order of "hard drives" which include USB drives as well.

This solution solved this problem on a number of computers where I tried to boot from a USB.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.