Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've run into a brick wall trying to get 12.04.1 LTS running on my new MacBook Air 5,2 (2012 13" model). The problem I keep getting is GRUB failing to install; here's the output from virtual terminal 4:

Sep  9 02:02:57 grub-installer: info: Installing grub on '/dev/sda5'
Sep  9 02:02:58 grub-installer: info: grub-install supports --no-floppy
Sep  9 02:02:58 grub-installer: info: Running chroot /target grub-install  --no-floppy --force "/dev/sda5"
Sep  9 02:02:58 grub-installer: /usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
Sep  9 02:02:58 grub-installer: error: Running 'grub-install  --no-floppy --force "/dev/sda5"' failed.

I'm trying to dual-boot OS X and Ubuntu. I first resized the HFS+ partition in Disk Utility using OS X, then installed rEFIt, then dd'd the alternate-amd64+mac version of the disk image to a USB stick and booted off that. I'm also setting noapic before beginning the installation as recommended in this forum post.

At first, following the advice in that post, I tried the daily image from cdimage.ubuntu.com/precise/daily/current/ and was getting an error message almost identical to the above. Then, hoping the release version would be more stable, I dd'd "ubuntu-12.04.1-alternate-amd64+mac.iso" from cdimage.ubuntu.com/releases/12.04/release/ to my USB stick instead. Same result.

/dev/sda5 is a 1.0 MB partition of type "Reserved BIOS boot area".

Googling the "cannot find a device for /boot/grub" error doesn't seem to turn up anything relevant to my situation.

Any ideas how I can solve this?

share|improve this question

closed as too localized by Jorge Castro, Eliah Kagan, fossfreedom Dec 19 '12 at 9:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Did you follow the detailed instructions on Ubuntu's Apple Intel Installation documentation page?

According to that, you should be installing GRUB to Ubuntu's root partition (assuming the instructions are followed verbatim, that partition would be /dev/sda3, but your mileage may vary).

share|improve this answer
    
Oops, sorry I didn't notice this until now. I actually worked around this by installing Ubuntu 12.10 beta instead, which worked almost perfectly from the regular installer. Pretty sure I did what your link says, but it's now moot for me personally. –  Scott F Oct 4 '12 at 4:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.