Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I uninstalled indicator-messages because I'd rather have separate icons for my programs. The problem I have now is that pidgin icon won't show up (while others do, like empathy, skype and so on). Or to be more precise, it shows up but is transparent:

Invisible pidgin icon spotted!

When I use the main launcher and there is the dark effect on the top bar, here is how it looks (black square):

enter image description here

To summarize where I'm at with the packages, I've uninstalled:

  • indicator-messages
  • indicator-status-provider-mc5
  • indicator-status-provider-pidgin

And systray whitelist is set to ['all'] already.

share|improve this question
@RolandTaylor not a duplicate, systray whitelist is set to all already. – Mog Sep 8 '12 at 23:31
oh okay, I think I know what your problem is now. – RolandiXor Sep 8 '12 at 23:33

Remove the pidgin status provider:

sudo apt-get remove indicator-status-provider-pidgin

Then restart Pidgin and it's icon should show up. If it does not, then just make sure to double check that you have Pidgin's tray icon enabled in its preferences (in case this option was disabled when you had the indicator installed).

To be completely certain (now I noticed that the icon is there but transparent), check the following:

  • Ensure that you are using the default icon theme in pidgin.
  • Try using one of the default Ubuntu icon themes if you are not already.
share|improve this answer
Well, I uninstalled the indicator status provider and checked all the other points but the problem is still there. Strange! Thanks for helping out though :) – Mog Sep 8 '12 at 23:55

If you can get back to the original transparent icon I suggest that you try changing your theme, as follows:

  1. Select the gear in the top right of your screen
  2. Choose "Appearance"
  3. On the default "Look" tab, toward the bottom, is a place to select an alternate theme.

I've seen a case where a program was using an icon without sufficient contrast with the chosen theme and the problem was eliminated by using a different theme, and therefore a different top panel background color.

share|improve this answer
doesn't solve the program - exact same symptoms (trasparent icon when in normal mode and black square when launcher is on). Thanks for helping though it's appreciated :) – Mog Sep 9 '12 at 0:42
s/program/problem/ – Mog Sep 9 '12 at 17:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.