Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed libdvdcss2, but I still get this error when trying to play DVDs:

enter image description here

libdvdread4 was installed by default (This is a new System76 Pangolin Performance). I ran the script, and it completed with no problems.

I can confirm that libdvdread4 and libdvdcss2 are installed:

mac9416@charlotte:~$ dpkg -l | grep dvdcss
ii  libdvdcss2                                 1.2.12-0.0medibuntu1                    Simple foundation for reading DVDs - runtime libraries
mac9416@charlotte:~$ dpkg -l | grep dvdread
ii  libdvdread4                                4.2.0-1ubuntu3                          library for reading DVDs
share|improve this question
Try installing libdvdread4, from this related question:… – Steve Sep 8 '12 at 19:42
How did you install it? What does dpkg -l | grep dvdcss show? – January Sep 8 '12 at 19:42
Thanks for your suggestions! I've added information to my post. – mac9416 Sep 8 '12 at 21:10

The instructions on the Ubuntu Documentation site were quite right. As david6 pointed out, I simply needed to read further down the page and set the region code.

The process:

1. Install libdvdcss

sudo /usr/share/doc/libdvdread4/

(libdvdread4 came installed with the laptop.)

2. Set my region code

After making sure the universe repositories were enabled:

sudo apt-get install regionset

Before setting my region code, I read the regionset documentation at /usr/share/doc/regionset/README.

sudo regionset

I set my region to 0, North America.

3. Fix poor playback

After setting my region code, playback was possible, but the video was very distorted. So I read further down the DVD playback page. Deleting ~/.dvdcss/ did the trick.

rm -R ~/.dvdcss/

Playback still isn't perfect... In Totem media player, the menu is slightly distorted, and in VLC I have to disable menus entirely. But once the video is rolling, everything works fine. Thank you January and david6 for your help!

share|improve this answer
there's just one additional thing I had to do. I was not able to set the region because the dvd wouldn't be read at all (could not read /dev/dvd). There was no dvd folder in /dev so I created a symbolic link using "cd /dev" then "sudo ln -s sr0 dvd" (without the quotes off course) Otherwise thank you very much – William Nov 17 '13 at 21:47
As an anonymous user pointed out: "According to the region codes Zero is not a region code - it is a non region code." I'll add to this that while, as far as I know, using 0 here may be the best thing to do, someone who does want to specify the region code for North America should use 1 instead of 0 (…). – Eliah Kagan Jan 18 '14 at 7:46

This should work:

sudo apt-get install libdvdread4
sudo sh /usr/share/doc/libdvdread4/
share|improve this answer

Try re-installing all DVD support:

sudo apt-get -y install libdvdcss2 libdvdnav4 libdvdread4
sudo /usr/share/doc/libdvdread4/
share|improve this answer
Should I remove the three packages first? If so, I'll give it a try tomorrow when I have an unlimited internet connection. – mac9416 Sep 8 '12 at 22:36
Yes, first remove then install. Also make sure you are fully updated as well. – david6 Sep 8 '12 at 22:56
I removed the three packages (which also removed quite a few dependencies), then reinstalled them. But I'm still getting the same error. I also tried using dpkg-reconfigure on the packages. – mac9416 Sep 9 '12 at 18:01
I have those exact versions installed, on having no issues with DVD playback. What other factor could be affecting this? Region codes? Video player (software)? etc. – david6 Sep 9 '12 at 22:33
Region codes could have something to do with it... I'll investigate that further. It's probably not the player. I've tried Totem and VLC. VLC doesn't throw an error: it just croaks. The command-line errors just spew "failed to decrypt" messages. I guess the final thing could be the optical drive... but what are the odds of that? I'll find out when I install XP in a Virtualbox later this week. – mac9416 Sep 10 '12 at 2:09

I had the exact same problem and it was just region set all the time I followed the steps on the following site which then got it working for me :) I still can't understand why I didn't have to use it on the last version of ubuntu but oh well at least it works and I know to look at it next time if I need to. Use the following link for steps...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.