Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed 64bit Ubuntu 12.04.1 LTS on my Inspiron 1720 laptop as a dual-boot with Windows 7.

When I boot up Ubuntu, it gets to the log in screen just fine but after logging in it gets stuck with the default desktop background display only. I can move the cursor around but I can't get any response from it. No response from any keyboard commands or from any clicking and I eventually have to force it off.

I can log in recovery mode just fine without any issue so I've updated Ubuntu in recovery mode but I still have the same issue.

share|improve this question

Not exactly a solution but try this:

  • Log into your desktop and wait until the hard drive stop reading. The way you describe it seems like unity is not loading properly.

  • After this, switch and log into a tty. You can do this pressing Ctrl+Alt+F6 and log into the terminal.

  • Change the variable DISPLAY so the next commands will affect the graphic environment:

    export DISPLAY=:0.0

  • Execute this:

    compiz --replace &

  • This should make compiz try to restart. You should return to the GUI (Ctrl+Alt+F7 or Ctrl+Alt+right arrow) and see if it loads the desktop. Any error message would show up in the tty6 you executed the command.

  • If this doesn't work, try to reset unity to defaults, in the same tty6:

    unity --reset

  • And repeat the process, try to reload compiz/unity again and see if it works. As a last advice if this is not working you could install an alternative desktop manager like gnome-shell or xfce:

sudo apt-get install gnome-shell


sudo apt-get install xubuntu-desktop

That way you'll have at least an usable desktop to surf the web and search the answer. It may be a problem with your graphic drivers and after installing them it may work. What graphic card are you using? I remember having a lot of problems with ATI cards...

Wish it helps, good luck!

share|improve this answer
Tried all the options, didn't seem to do fix the issue so I continued to log in and use Ubuntu through recovery mode. Tried to log in regular recently and it works fine now. Not sure why but I assume what you suggested helped so thank you. I have an NVIDIA graphics card. – Craig Sep 23 '12 at 6:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.