Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have HP ProBook 4530s laptop with AMD Radeon HD 6490M graphics card. After installing Ubuntu it runs on Intel Sandybridge graphics. The Ubuntu community page says: "By default Ubuntu will use the open source ATI or Radeon driver for cards manufactured by AMD/ATI." I already have installed the required driver packages: xserver-xorg-video-ati xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-intel xserver-xorg-video-all, but it uses Intel driver anyway. When I'm uninstalling the Intel driver (xserver-xorg-video-intel) and rebooting, Radeon graphics works, it uses Gallium driver, but only 2D session loads. This page says: "No configuration is necessary for ATI driver in the modern versions of Ubuntu." and I'm using Ubuntu 12.04. What's wrong? Please help!! I got tired!!! P.S. I don't want the proprietary FGLRX driver! It's really buggy on my system!!! Thanks! :)

share|improve this question
    
Do you by chance have hybrid graphics? –  Uri Herrera Sep 8 '12 at 18:28
    
Yes, I have hybrid graphics. –  giogziro95 Sep 8 '12 at 19:53
    
Can you disable the Intel GPU from the BIOS? –  Uri Herrera Sep 8 '12 at 20:01
    
Unfortunately I can't. –  giogziro95 Sep 8 '12 at 20:02

2 Answers 2

Have you tried this?

sudo apt-get remove --purge xorg-driver-fglrx fglrx*  
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases  
sudo dpkg-reconfigure xserver-xorg

sudo apt-get install --reinstall xserver-xorg-core

This should make your system use the opensource driver. It worked for me. I have a different computer but it has a Radeon HD 4000 series

share|improve this answer
    
Nah! It runs on Intel GPU :( People are having a lot of problems caused by their AMD graphics card. –  giogziro95 Nov 5 '12 at 0:53

Definetily the issue that I faced. I wrote this article as a solution that worked for me.

ATI Radeon HD 6750 Ubuntu 13.10

share|improve this answer
    
You are much appreciated for trying to help a person. But you must give context for links ie explain whatever is in the link you are providing. See here :- askubuntu.com/help/how-to-answer under "Provide context for links" heading. This is not intended to offend you but just to make your answer better and useful for the community. –  Venki Apr 12 at 18:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.