Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My built-in microphone doesn't seem to be detected, because I cannot use it to record my voice in Audacity and it's also not working in Skype.

Any solution for my problem?

Laptop: Axioo MNC

share|improve this question
2  
Did you check that the proper device is set in the input device tab of sound settings ? –  João Pinto Dec 22 '10 at 20:29
    
To get to Sound Settings/Prefereces click on the sound menu in the top right panel and then click "Sound Preferences" –  8128 Dec 22 '10 at 21:53

6 Answers 6

I found that if I opened up the

Applications > Sound and Video > PulseAudio Volume Control

and under 'Configuration' changed my computer from 'Analog Stereo Output' to 'Analog Stereo Duplex', the mic was recognized and now works. This also resulted in the

System > Preferences > Sound

settings box showing the mic, whereas it did not show up before.

share|improve this answer

As suggested by the comments: make sure that you have set the microphone as input sound device in the sound preferences.

  • To open the sound preferences, click on the sound indicator applet in the top right corner:

  • Then select the Input tab:



    Make sure that the input device isn't muted (checkbox), and that you've selected your microphone from the list of devices in the lower part of the window (not shown here).

If the microphone still won't work, make sure it's enabled in the BIOS setup and that you haven't turned it off via some Fn-shortcuts of your notebook.

share|improve this answer

This could be a regression bug that I reported in 2009 and has not yet been solved. I asked a the same question before here and here. I didn't find any solution. I wonder if you have the same Intel 82801H sound card.

I had to buy an external USB mic.

share|improve this answer

You can also try to set up the bar which appears with the label "Input volume", in the "Input" tab of "Sound Preferences" window, the one that appears on the above picture.

share|improve this answer

I gave up on built in microphones. When I use skype or other type programs I use a bluetooth headset that I also use with my cell phone. If your laptop does not have bluetooth you can add a USB bluetooth dongle. You can find them for a cost from $15 to $30. They are tiny so it can be left plugged in all the time. Most headsets have a technology called multipoint which allows you to pair with more than one device simultaneously. When I need to make a skype call I press the call button on the headset and it connects to the bluetooth service on my computer and takes over the speaker and mic feature. Since it is basically wireless headset I can walk away from the computer while still in the call.

I know this does not specifically answer your original question but may give you a better option.

share|improve this answer

Take a look at this:

Skype doesn't find my audio input

Original answer by @Treviño, Posted here for your convenience:

The only way I've found to make my internal mic work in my laptops is to use pavucontrol (install it from the homonymous package) and disabling the volume of a channel (the right or the left one), since most of microphones are mono in fact.

This is an huge workaround, by the way. I guess that this annoying bug should be fixed somewhere!

Pavucontrol - Input volume settings

It worked for me in several laptops with stereo and/or mono built in microphone (on screen or panel).

Additionally, you may wish to take a look at your sound preferences, mentioned in the same page. Click this link: Skype doesn't find my audio input (this will lead you to a different answer in the same page).

Also posted here for your convenience:

Under Sound Preferences, please post the "Hardware Tab" in order to check your profile, which should use at least an output + an input being in use. Otherwise, your hardware is not using the input profile which can be chosen right there.

This answer may be changed after your posting in order to give you further details. Here is a sample. Thank you.

enter image description here

Edit -- Here is the conversation in the general chat room.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.