Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a very messed up installation of Gimp.

Some time ago I installed Gimpshop or Gimphoto (can't really remember which) and it installed Gimp 2.2. Didn't work for me and tried to remove it.

I've followed all Gimp remove, autoremove, clean, update and upgrade instructions I've found here to no avail. Now Software Center doesn't even show 2.8 but instead it does 2.6.

I've installed and removed Gimp from terminal nth times. Running Gimp from the dash doesn't do anything but entering "Gimp" in the terminal prompt gives me a 2.2 installation screen.

Gimp 2.2 install screen

Cannot for the life of me find and remove the darn leftover garbage.

How can I completely clean my system (12.04, fully updated today) from everything Gimp so I can give 2.8 a try?

Anticipated apologies if this is a dupe but I've run through all messages with a Gimp tag and none has helped me.

sudo apt-get install -f gives me 0,0,0,0.

Thanks in advance.

share|improve this question

2 Answers 2

Ubuntu 12.04 does not come with Gimp 2.8, it still includes Gimp 2.6.

If you want to try 2.8, you can either wait until Ubuntu 12.10 comes out, or to add a PPA for Gimp 2.8. Here are the instructions how to install Gimp 2.8 on WebUpd8.

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

Before doing this you might run find / -name gimp to find and possibly remove all files with that name - I suspect that you just have a file with this name in your home directory or something like that, that's why entering gimp interminal starts some installer.

share|improve this answer
    
Sergey, many thanks! The find / -name gimp command in a terminal revealed a lot of 2.0 and 2.2 garbage. I had to go "su" in order to delete them but it's done now. –  Jorge M. Treviño Sep 8 '12 at 6:43
1  
What I cannot get to work is the install of 2.8; the terminal still installs 2.6. –  Jorge M. Treviño Sep 8 '12 at 7:29
    
@JorgeM.Treviño I had the same problem with you. Go to Update Manager, click Settings, Other Software tab and make sure that the otto-kesselgulasch/gimp entries are selected! –  ECII Dec 28 '13 at 16:05

Use this if gimp is already installed

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get dist-upgrade
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.