Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My pc has an Intel DH57JG mainboard, I've installed wine, launching sketchup I receive error that I don't have OpenGL installed, is there a way to configure/install it? On my previous pc with an NVidia video card installing official NVidia driver resolved it. Is there is a way to do the same with the Intel card?

Running locate libgl on a terminal returns no results.

thanks in advance.

share|improve this question
sounds to me like wine cannot find the required libraries. run locate libgl* in a terminal and attach the output to your question. – RolandiXor Dec 22 '10 at 17:17
up vote 11 down vote accepted

I've installed SketchUp 8 and had the same error.

Here's how I got it to work:

  • Open a Terminal, or press Alt+F2 and type

    wine regedit
  • Navigate to HKEY_CURRENT_USER → Software → Google → SketchUp8 → GLConfig → Display

  • Change the value of HW_OK to 1 (so that it shows up as 0x00000001 (1))

Then start SketchUp

I hope this works for you as well :)

share|improve this answer
you are really a Ubuntu Guru!!! Thanks my proble is result! – haltman Feb 3 '11 at 19:31
Stefano, Great. A very clear and concise instruction,which worked first time. Many thanks Bob McM – user11058 Feb 18 '11 at 13:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.