Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since the installation of 12.4, Firefox only starts in a small window. I'm getting really pissed about that. Does anyone know how to fix that? Any kind of help would be really appreciated!!!

share|improve this question
    
How did you installed Firefox? I guess, you are not using Ubuntu but another derivative such as Lubuntu or Xubuntu. Can you ensure this? –  Anwar Shah Sep 8 '12 at 0:30
    
Can you describe your problem in more detail like add a snapshot?Is it the case that even if you close the Firefox maximized,it starts in a small window? –  IgnitE Sep 8 '12 at 0:32
    
yes it is, and no its precise ubuntu not kubuntu or lubuntu –  Nick Bailuc Sep 8 '12 at 22:18
    
Plz check the answer below and hope it helps –  Iori Sep 9 '12 at 12:54
    
Should probably be closed as Too Localized, see OP's answer below. –  Tom Brossman Sep 9 '12 at 16:01
add comment

closed as too localized by Tom Brossman, Jorge Castro, Anwar Shah, John S Gruber, Florian Diesch Sep 10 '12 at 4:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

up vote 2 down vote accepted

This usually happends when the localstore.rdf file is corrupted.

It is located in ~/.mozilla/firefox/<profile_name>/.

You can use either of the following solutions:

  • If you have a backup copy of localstore.rdf file from a working profile, a quick remedy is closing Firefox and overwriting the localstore.rdf file in the Firefox profile folder with your backup copy.

  • If you don't have a backup copy just delete the file from the path mentioned above, and Firefox will generate a new copy for you.

  • If you're using Firefox 15, just reset the firefox profile from History > Reset Firefox.

    Important Note (if you're using Reset Firefox):

All of your Firefox settings and personal information is stored in your profile folder. The reset feature works by creating a new profile folder for you while saving your:

  • Bookmarks
  • Browsing history
  • Passwords
  • Cookies
  • Web form auto-fill information

The following items are either NOT SAVED or set to their defaults.

  • Extensions and themes

  • Open tabs, windows and tab groups

  • Site-specific preferences, search engines, personal dictionary, download history, DOM storage, security certificate settings, security device settings, download actions, plugin MIME types, toolbar customizations and user styles

After the reset is finished, your old Firefox profile information will be placed on your desktop in a folder named "Old Firefox Data."

Source and Further Information:

share|improve this answer
add comment

Most of the OS have the ability to save the last thing you do which an application

so try to maximuze you firefox and then close it and when you open it. it will open in large window.

I hope this helps

Edit

ok here is the link http://kb.mozillazine.org/Command_line_arguments

you have to use command line to set your firefox width and height

you can find out your screen width height and set is according to that

firefox -width 800 -height 500

Hope this helps

share|improve this answer
    
you think i havent done that? i do it everytime –  Nick Bailuc Sep 8 '12 at 22:15
add comment

This problem actually went away after I opened Firefox, maximized it, then closed it and I repeated the process multiple times.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.