Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.04 (dual-boot, kept Windows just in case) on my new Acer Aspire One 756-877. As soon as I installed it, I also installed the Broadcom driver, since Wi-Fi wasn't working, and that solved it right away. But when I tried Bluetooth, I had a problem that I see is quite recurring:

  • The hardware is on (and working fine under Windows)
  • The icon shows up on the menu, giving me the options of turning Bluetooth on or off, and then just "Bluetooth preferences".
  • I can apparently turn it on that way, which only lights up the icon but makes no difference at all (and doesn't give any other options in the Bluetooth menu)
  • When I open "Bluetooth preferences" (whether Bluetooth is apparently on or off, it makes no difference), it says it's disabled and will not let me slide the button to enable it. I've rebooted, but nothing happens.
  • The material is Broadcom and the port (if it's relevant at all) is Port_#0001.Hub_#0003

I tried the following commands suggested in other similar questions, with no result at all:

sudo dmesg | grep blue

sudo service bluetooth start

sudo /etc/init.d/bluetooth start

Any other clues on what I can do?

share|improve this question

1 Answer 1

Check the BIOS. If Bluetooth is disabled or if there is an external switch or keyboard key to enable it, try these.

share|improve this answer
    
Thanks, rmaultz, but yes, I started by checking that the hardware is actually enabled (and works fine under windows). Regarding the keyboard keys, curiously the "Fn+F3" that opens the wifi+bluetooth preferences under windows is the only one of the computer's preset keyboard commands that won't work under ubuntu... –  PCh Sep 9 '12 at 10:41
    
(And by the way, when I request to start bluetooth in the terminal (the commands I mentioned, that were suggested in response to other similar questions), it says it is already working) –  PCh Sep 9 '12 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.