Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I plug my iPod Touch (2nd gen) into my MacBook running Ubuntu 10.10 I get the following error:

DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

It will show up in the file browser but whenever I try to mount it I get that error.

EDIT: I thought that this might be because I had it plugged into a dock, but I tried plugging it in directly to the MacBook with the USB Cable and it still does not work, same error message.

share|improve this question
    
I get this same error. Are you running iOS 4.2.1 on your iPod touch? If so, that's the issue. Apple changed something inbetween 4.1 and 4.2.1. –  jrg Dec 28 '10 at 22:13
    
Yeah, I am running 4.2.1, so does that make this unsolvable? –  Mark Szymanski Dec 28 '10 at 22:57
add comment

migrated from superuser.com Dec 22 '10 at 15:27

This question came from our site for computer enthusiasts and power users.

4 Answers

sudo add-apt-repository ppa:pmcenery/ppa
sudo apt-get update
sudo apt-get dist-upgrade

i did it yesterday, and worked flawlessly for me (4.2.1 iOS)

share|improve this answer
2  
HELL YES! The above post fixed my issue! iPod touch 4.2.1 :-) THANK YOU –  user9810 Jan 28 '11 at 22:17
    
you're welcome :) by the way, could you mark my answer as the right one? thanks! –  wifi Jan 29 '11 at 12:35
    
+1, that worked! On an iPhone 4, version 4.2.1. Took a long time to process those three commands though (around 10 minutes). –  Torben Gundtofte-Bruun Mar 24 '11 at 20:09
1  
It worked for me too; you should really consider marking this answer as accepted! –  Adrian Petrescu Apr 2 '11 at 1:55
    
Thanks buddy, worked for me. –  kobrien Apr 10 '11 at 0:35
add comment

I'm having the exact same problem mounting my iPAd running iOS 4.2.1. I run Ubuntu desktop 10.10. If anyone has a solution that would be nice.

My next solution is to run windows 7 in Virtual Box, then install iTunes. I REALLY wish that there were an itunes build for Ubuntu. I tried running Wine and then installing iTunes. Never could get it to work.

///Update

I just followed the instructions in this link: http://www.webupd8.org/2010/12/get-ios4-mountsync-working-in-ubuntu.html

I now am able to mount my iPad!

share|improve this answer
    
This isn't an answer. Post as a separate question, otherwise it won't be possible to answer your question. –  Mark Szymanski Dec 30 '10 at 23:36
    
Keith's solution (Dec 30 '10) worked for me as well. Thanks, Keith! –  Herta Jan 17 '11 at 0:04
add comment
up vote -1 down vote accepted

Well, it seems that since I am running 4.2.1, it just isn't possible.

share|improve this answer
add comment

Follow this post, it does the trick:

http://ubuntuforums.org/showpost.php?p=10205459&postcount=32

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.