Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hope s.o. can help me ....

According to a page I found I should do this:

sudo add-apt-repository ppa:cinelerra-ppa/ppa
sudo apt-get update
sudo apt-get install cinelerra

But that led to the problem that the package "libmpeg3cine" could not be installed because some files were already installed by package "mpeg3-utils". The package system seemed broken because of a defective package. So I tried to uninstall it - which did not work. It worked only by running sudo gedit /var/lib/dpkg/status and removing the "cinelerra" section.

Then I tried to compile it according to the g-raffa compilation howto.

But this did not work until "make". Then I got the following errors:

collect2: ld gab 1 als Ende-Status zurück
make[3]: *** [x264] Fehler 1
make[3]: Verlasse Verzeichnis '/home/peterl/system/cinelerra-4.3/quicktime/thirdparty/x264.052906'
make[2]: *** [x86_64/x264] Fehler 2
make[2]: Verlasse Verzeichnis '/home/peterl/system/cinelerra-4.3/quicktime'
make[1]: *** [all] Fehler 2
make[1]: Verlasse Verzeichnis '/home/peterl/system/cinelerra-4.3'
make: *** [all] Fehler 2

I even tried the newer version but that stopped earlier I think with the following error message:

/usr/bin/ld: .libs/libmpeg3.o: relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
.libs/libmpeg3.o: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [libmpeg3hv.la] Fehler 1
make[3]: Verlasse Verzeichnis '/home/peterl/system/cinelerra-cv-old/libmpeg3'
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlasse Verzeichnis '/home/peterl/system/cinelerra-cv-old/libmpeg3'
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlasse Verzeichnis '/home/peterl/system/cinelerra-cv-old'
make: *** [all] Fehler 2

As far as I know it says that I have to recompile with "-fPIC" So I tried to "configure" with:

./configure --with-buildinfo=git/recompile --enable-mmx --without-fpic --without-pic

But that seemed not to help as well. I also tried as mentioned with:

./configure --with-buildinfo=git/recompile

But that did not work as well.

Now I do not know what else I could try to get Cinelerra running.

Maybe there is another howto? Hope Someone can help me please.

share|improve this question

closed as too localized by Uri Herrera, John S Gruber, Amith KK, LnxSlck, Mitch Oct 5 '12 at 14:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer 1

I found the error. My problem was that I had compiled ffmpeg and x264 before manualla and installed them. But I think that was not supported somehow.

After I uninstalled them and installed to official versions the problem disappeared and I was able to run "make" without errors.

Sorry for this question cuz the problem was selfmade.

Anyway thanks to all and esp. to Roland Taylor for editing my 1. Question here.

cu

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.