Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I certainly like notifications in 12.04, but depending on the work I do they can be quite distracting.

Is there an official way or a tweak to temporarily deactivate notifications?

UPDATE: To clearify, I am looking for a way to do that in Unity.

share|improve this question
this is a wishlist bug report: – fossfreedom Sep 7 '12 at 15:02

4 Answers 4

I don't believe there's an official way, but it's easy enough to disable in the terminal (for presentations, etc.):

  sudo chmod 000 /usr/lib/notify-osd/notify-osd
  killall notify-osd

Afterward, just chmod it back to 755 and notifications will resume.


share|improve this answer
You need root access to do this. That's not very practical. – Marco Sep 7 '12 at 12:05

This is how I achieved it

Create a sh file called and paste this line

killall -s SIGSTOP notify-osd

Create another sh file and and paste following line

killall -s SIGCONT notify-osd

Then goto system settings > keyboard and assign a shortcut for it.

Simple :)

share|improve this answer

Do the following

simply disable process notify-osd from system monitor

Stop Process : To stop popping up notifications

Continue Process : To continue popping up notifications

share|improve this answer
how is this different to the answer provided by tigerjack89 40 minutes earlier? – Graham Mar 22 at 9:58
I had already typed answer but I had to switch tab and till the time his answer was not there. After sometime when I switched back to this tab then posted my reply. – MohdSohail Mar 22 at 10:15

You can disable popup notifications (the bubbles) graphically. Open System Monitor, find the process named notify-osd, right click on it and select stop; if you want notifications back, right click again on the process and click continue.


  1. You can test if it's working trying to change audio level from keyboard.
  2. Be sure that there aren't bubbles opened when you stop notify-osd, otherwise they remain locked there.
  3. I don't know why, but when notify-osd is disabled, shortcuts doesn't work well; I mean, all shortcuts (even Ctrl+Alt+L for example). This doesn't always happen and is particularly evident when you use keyboard shortcuts for audio (e.g. to mute, increase or decrease volume, but also to pause or change the music).
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.