Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm stuck. Ubuntu 11.10 was working fine. I tried to create a desktop icon that I could click and run a Terminal command. (not launch a program, just run a command to set something). I don't know what I did, but now I can't get Terminal to run at all. I can't click on Terminal in the Launchbar or use alt-F2. If I try, I see a VERY quick box open and close. If I switch to another user, Terminal does open and work fine? I can't even get it to open gconfig or x-term or x-term manager? Does anyone know how to reset Terminal without being able to get into Terminal? I tried going into synaptic and removing Terminal, and then re-installing it, but it didn't change the behavior at all, it still won't open.

share|improve this question
1  
What command was in your desktop icon? –  Anwar Shah Sep 7 '12 at 10:34
add comment

2 Answers 2

up vote 3 down vote accepted
  1. Press Ctrl + Alt + F1

  2. In the virtual terminal, give your username and password to login.

  3. Execute these commands:

     rm -r ~/.gconf/apps/gnome-terminal
     gconftools --recursive-unset /apps/gnome-terminal
    

And see what happens.

share|improve this answer
    
PERFECT! Thanks Anwar, that fixed it! –  N.T. Sep 7 '12 at 19:48
add comment

Install another terminal emulator, and try to run gnome-terminal, see what kind of error messages you get, if any.

You can also use ctrl-alt-f1 to switch to terminal mode, but starting X programs from there might be tricky.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.