Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently re-purposed my old desktop PC as a 'server' running Ubuntu LTS 12.04. I want to use the machine as my primary squeezebox server in place of my HTPC MacMini (to reduce the strain on the MacMini). I managed to install squeezebox server without to much difficulty and added Music folder of my 'Home' folder to the library - all good and it worked fine.

I then realised that the disk was almost completely full and decided to install a second drive in the machine and move the music to that so that the primary drive could be used for other things. I installed a 1.5TB drive in the machine and formatted it as one partition with ext4 using Ubuntu's 'Disk Utility' app.

I then moved all my music to a 'Music' folder on the new drive using nautilus. The problem is that I cannot add the new drive/folder in the LMS web settings.

The old music folder was located at: /home//Music (This can be found fine by clicking browse in LMS web settings)

When I go to the settings page at 'Basic Settings','Media Folders' and click browse, I cannot find the new drive - it is not showing up.

The new drive is located at: /media/mediadisk

I can access the new drive without any problems using nautilus, or by navigating through the terminal, but if I use the 'browse' feature from within LMS web settings the folder cannot be found. (The 'mediadisk' drive is not showing up in the 'media' folder)

I have even tried pasting: /media/mediadisk/Music into the 'Media Folders' field but nothing works!

I must confess I am pretty new to Linux but if I was to guess I would say it was a problem with the permissions, right? Can anyone help?

share|improve this question

The new drive is not actually at /media/mediadisk/Music. It is located at something like /dev/sda or /dev/sdb. Try looking at this question for more information.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.