Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to run Unity 2d in xubuntu, I installed the packages but when I try to run it I get

[FATAL] Settings schema 'com.canonical.Unity' is not installed

How can I get it to run? I'd like to install as little stuff as possible.

share|improve this question
    
What packages have you installed and how? If you've used coomand line, can you provide the commands. –  mikewhatever Sep 18 '12 at 19:11
    
I used synaptic, I searched for unity-2d and installed the main package. Since it did not work, I tried to install all the other packages found with this name but to no avail. –  Borsook Sep 19 '12 at 7:28
1  
@AntoineRodriguez - I am running 12.04 and it will be supported for years to come. And it's faster than Unity, computer I'm using runs very fast with XFCE and very slow with Unity, I wanted to test it with Unity 2d –  Borsook Sep 23 '12 at 16:59
add comment

3 Answers 3

up vote 4 down vote accepted
+50

I think unfortunately you will have to install more dependencies, and the one you are missing is gnome-session, without which unity 2d can't run, and you get the error message you received. This is actually detailed at Launchpad; installing unity 2d manually from Synaptic does not automatically pull in the correct dependencies.

Running an apt-cache rdepends unity-2d proves this:

unity-2d
Reverse Depends:
  unity-2d-dbg
  unity-2d-common
  libunity9
  unity-2d-dbg
  unity-2d-common
  ubuntu-desktop
  libunity9
  gnome-session
 |gnome-session

If you don't want absolutely everything that gnome-session includes, you could try installing it with the --no-install-recommends flag and this will install just the essential elements needed for unity-2d.

Run in terminal

sudo apt-get install gnome-session --no-install-recommends

It should not be necessary to install the ubuntu-desktop package as well, but keep that in mind if all else fails.

Using unity-2d should now be possible and it should be a login option at the Xubuntu screen and if you have any visual defects in it is also worth installing the following, according to this Launchpad report.

sudo apt-get install light-themes ubuntu-mono ubuntu-wallpapers-precise gnome-themes-standard

As the two bug reports at Launchpad have proven, you do need to install a fair amount of things to run unity-2d on Xubuntu.

share|improve this answer
    
"then run it again without the --no-install-recommends", I think it cannot be done in that way after installation is done. Because you will be given a message like "gnome-session is already in the newest version" –  Anwar Shah Sep 21 '12 at 11:41
    
@Anwar Yes you are correct- I was thinking of something else at the time-will edit my answer. –  user76204 Sep 21 '12 at 11:59
add comment

Check out your dependencies, when I saw this in the past I used dpkg to list them and it turns out some of the dependencies were wrong and somehow unity-2d-places and unity-2d-spread were not installed.

share|improve this answer
1  
can you elaborate your answer a bit? I think, it would be very helpful –  Anwar Shah Sep 21 '12 at 11:46
add comment

I think you should install ubuntu-desktop package if you want to be sure to have all packages for unity:

sudo apt-get install ubuntu-desktop
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.