Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just set up my router. Reception is good throughout the house, with the exception of the computer with wireless dongle (an android phone and a laptop with a bilt-in wireless card connect terrificly). Dropouts are random, often and common (I stay conencted from 1 second to 10 minutes with the 1 second case the most common). When there are no other devices on the network, or when my neighbours have turned off their wireless routers, dropouts are infrequent.

I guess I have to set longer timeout and lower signal strength treshold, but do not know how to do that.

How shall I proceed to set up a, maybe slow, but reliable conenction? Here are excerts from some commands outputs.

OS: Ubuntu 10.04 x86_32
USB dongle: says just "TP-LINK", is pretty tiny
router: wired-wireless TP-LINK router, rated wireless speed 150Nbps
distance: 2 rooms i.e. 2 walls, 15 meters

wlan0     Link encap:Ethernet  HWaddr 54:e6:fc:8f:d4:73  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::56e6:fcff:fe8f:d473/64 Scope:Link
          RX packets:446 errors:0 dropped:481 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:144937 (144.9 KB)  TX bytes:0 (0.0 B)

wlan0     802.11b/g/n  li  ESSID:"WiFi"  
          Mode:Managed  Frequency=2.427 GHz  Access Point: 54:E6:FC:BC:50:FE   
          Bit Rate=300 Mb/s   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=65/100  Signal level=-71 dBm  Noise level=-102 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[ 2245.471876] ieee80211: Failed to reply on ADDBA_REQ as some capability is not ready(0, 1)
[ 2245.471886] =====>to send ADDBARSP

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     2      0        0 wlan0
link-local      *          U     1000   0        0 wlan0
default         UG    0      0        0 wlan0

Network manager conects at 2/3 signal power.

iwlist power:
wlan0     Supported modes :
                o Receive all packets (unicast & multicast)
                o Receive Unicast only (discard multicast)
                o Receive Multicast only (discard unicast)
          Fixed period  ;  min period:0us
                           max period:5s
          Fixed timeout ;  min timeout:0us
                           max timeout:65.535s
          Current mode:off

iwlist rate:
wlan0     12 available bit-rates :
      1 Mb/s
      2 Mb/s
      5.5 Mb/s
      11 Mb/s
      6 Mb/s
      9 Mb/s
      12 Mb/s
      18 Mb/s
      24 Mb/s
      36 Mb/s
      48 Mb/s
      54 Mb/s
          Current Bit Rate=300 Mb/s
share|improve this question

The key to your problem is the fact that when your neighbors turn off their WIFI's your problem disappears. You have interference from same or close channels. If you are able to,you need to change the frequency of your access point (computer).

You are currently at 2.427 GHz. That equals channel 4. Here is a reference link to the channel allocations.

Try moving to the highest channel authorized for your country and see if you get improvement. Then, if necessary, move down the list until you do get improvement. If you are in an apartment, you may have much interference and may never get a full specification performing connection but hopefully you can get a connection that won't disconnect.

Worst case, you may have to get off 2.4 Ghz or go to a cable connection.

Good luck.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.