Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed nagios3 on ubuntu server 10.04.1. It was working fine.

Today, I found it stopped and when I tried to start it using sudo /etc/init.d/nagios3 start, it did not start. I found this in the log file:

Nagios 3.2.0 starting... (PID=11729)
Local time is Wed Dec 22 14:15:31 2010
Caught SIGSEGV, shutting down...

I tried to remove and re-install it without success. After googling, it seems that no one has a solution for this. I don't want to install it from source unless it is really the last hope.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I've seen a couple of cases of people with this problem.

No-one seems to have reported a bug though - I would suggest you do this by pressing Alt+F2 and entering ubuntu-bug nagios3. This will greatly increase the chance that the Ubuntu nagios maintainers will be able to help you.

share|improve this answer

From the crash stacktrace I managed to work out that this is related to the Nagios update checking code. As a workaround, you can disable the update check, and Nagios should then work as normal (at least it does for me!). i.e. in /etc/nagios3/nagios.cfg set

check_for_updates=0

I've added the stacktrace and workaround to this bug report.

share|improve this answer
    
Thanks for your answer, but I can not try it! I have already re-installed a fresh ubuntu server. Installing nagios3 from source code did not fix the problem. –  Khaled Jan 6 '11 at 11:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.