Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 12.04 in my machine which was running windows 7. I have been trying to configure the audio to work exactly as it used to work in Windows but never been able to do so. I have followed this link exactly. I am still not getting the required configuration. aslamixer command shows me with 5 adjustable controls as shown below

  1. Master "adjustable"
  2. Speaker "adjustable"
  3. PCM "adjustable"
  4. Front "adjustable" AND
  5. Beep "adjustable"
  6. Mic Jack Mic In or Lin In
  7. S/PDIF OO "in a box"
  8. S/PDIF D OO "in a box"
  9. S/PDIF P DIGITAL or Analog M

    It does not detect the headset jack when plugged in. I here mean to say that the sound form the speakers does not go off when I plug in my headset jack. How can I make this working. Some other googling also did not help. I am on Hp Pavilion DV7 machine. The chip is IDT 92HD75B3X5 and the card is HDA ATI SB.

Edit: apaly -l gives the following output, I do have the inbuilt mic.

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1   
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]  
  Subdevices: 1/1   
  Subdevice #0: subdevice#0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]  
  Subdevices: 1/1   >
  Subdevice #0: subdevice #0
share|improve this question
    
The question you have followed is specific for Lubuntu, which doesn't have pulseaudio pre-install. Ubuntu has pulseaudio by default, and what you really should be searching for is jack sensing. If you want help, please post the output of aplay -l as is. Also, is there a built in mic? –  mikewhatever Sep 6 '12 at 21:47
    
@mikewhatever Thanks for the edit and comment –  tough Sep 6 '12 at 22:25
    
Thanks for the output. :~) –  mikewhatever Sep 7 '12 at 2:50

1 Answer 1

up vote 1 down vote accepted

I've found a bug report with exactly the same problem as well as audio devices. It's not a fix, but rather a workaround, but it seems to have worked for at least two users with HP's DV6s.

To try the workaround, open a terminal window (ctrl-alt-t), and copy/paste the following:

gksudo gedit /etc/modprobe.d/alsa-base.conf

...then add the following lines to the bottom of the file, save and exit.

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m4-1 enable_msi=1

To test, either reboot, or run pulseaudio -k && sudo alsa force-reload.

share|improve this answer
    
Thanks a lot for your help, it fixed my pain of a.. you deserve more than kudos. –  tough Sep 7 '12 at 14:21
    
Glad that worked for you. –  mikewhatever Sep 8 '12 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.