Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have asked a related question in different sites such as here in German and a related thread here, a different case in the latter though. The # dpkg-reconfigure console-setup is firing WARNING: Unknown X keysym "dead_belowcomma", some bug?

I almost solved the question here, basically: "/etc/default/keyboard" -modification and one-line "$ setxkbmap -option grp:caps_toggle -variant dvorak-intl,nodeadkeys, us,de,no &" -- but the layout-settings get reseted after reboot. I use Debian but I believe the same settings apply to Ubuntu hence asking here.

Helper questions

  1. So how can I get settings to stay after rebooting? Or # service gdm3 restart?

  2. Or better how can I configure international keyboard -layouts system wide?

  3. What about user-centric keyboard -configuration?

share|improve this question
    
Do the settings get reset when you log in and out again, without resetting? –  January Sep 6 '12 at 21:00

2 Answers 2

Solution #1, easy: go to keyboard layout settings, click on "Options", select the desired Caps Lock behaviour:

enter image description here

Solution #2, easy: put that command into your profile's startup. Press the win key and type startup, then use it to add the full command.

enter image description here

enter image description here

share|improve this answer
    
No, .profile is for shell initialisation, it is not read until you start a terminal. Either use the GUI as described above, or look into the .config/autostart/ directory. –  January Sep 8 '12 at 5:21
    
Just as I have described above. Press the Win key to show the Unity dialog, then type "startup" -- the icon for the startup settings should appear. Select it and you are at the screenshot above. I have added a screenshot above. –  January Sep 8 '12 at 11:33
1  
Cool, it would have saved us some time if you did mention that earlier (your question Is it gnome made me think that you assume that I am using Gnome). Open a terminal, type gnome-control-center and choose "keyboard layout". –  January Sep 8 '12 at 18:04
    
In the gnome-control-center, I did just a shortcut F1 to the command. It does not solve the problem but I need just to remember hit F1 in the start. –  hhh Sep 8 '12 at 19:44

I feel the solution is close to some trial below. I am getting some WARNING now with default keyboard -adjusting, third trial, so cannot test things fully. I am co-operating with guys such as Trem.* in #Debian (Freenode), we haven't yet found a solution but below some of our working to diagnose the issue. The # dpkg-reconfigure console-setup should be enough to tune KBD but not sure with CapsLk -toggling, anyway some trials below.

Trial 1: not working

$ cat /etc/default/keyboard

XKBMODEL="pc105"
XKBLAYOUT="us,de,no"
XKBVARIANT="dvorak-intl,nodeadkeys,"
XKBOPTIONS="grp:caps_toggle"

Trial 2: not working

The basic idea is to configure the X -configuration files in certain level. For some reason, the keyboard settings get overwritten by some other settings, even though trying almost the highest level ie 98.

# echo "setxkbmap -option grp:caps_toggle -variant dvorak-intl,nodeadkeys, us,de,no &">>/etc/X11/Xsession.d/39x11-keyboard
# echo "exec /etc/X11/Xsession.d/39x11-keyboard" >>/etc/X11/Xsession.d/99x11-common_start

Then restarting-X does not work which is clear because the Caps-Lock -toggle not working -- it was because the settings got over-written # echo 'echo "Did run 001">/tmp/KBDrunned001' >>/39x11-keyboard. So

# mv /etc/X11/Xsession.d/39x11-keyboard /etc/X11/Xsession.d/98x11-keyboard

It did not work because the settings got over-written. Apparently some 99-level-thing or other 98-level-thing overwrites the keyboard -settings.

Trial 3: not working

It fires error in the position after setting up the font size, keeping default 16, did not even ask about layouts or Cap-Lock -toggling.

# dpkg-reconfigure console-setup
WARNING: Unknown X keysym "dead_belowcomma"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.