Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04. One of my classes require that I install the Qt libraries and SDK, however, I can neither install the 32-bit or 64 bit version. I changed both into executable files, but ubuntu refuses to even run the 32-bit setup. When I run the 64-bit setup, it will work until it asks me to choose a directory. After I click next the setup will slowly disappear and the computer becomes incredibly slow. When I click the icon for the Qt setup, the workspace switcher comes up, but no window.

share|improve this question
add comment

1 Answer 1

All you need to do is use the package manager. If I understand you correctly it sounds like you tried to actually download a binary from their website, but it is unclear.

In windows this is standard, but in Linux or Ubuntu we use package managers or even the Software Store.

Try

sudo apt-get install qt-sdk

Let me know if this helps.

A side note generally Ubuntu doesn't worry about file extensions and if you can't execute a binary file it is probably due to permissions not being set. Try right clicking on the file and add the execution permission to the file, but generally you can get everything from a PPA or Apt-Get.

share|improve this answer
1  
Thanks this helped, I was able to install it from the software center. The reason I tried the downloading the file from online is because I had installed it that way earlier when I was running Ubuntu on a virtual machine, but it was super slow. –  user87982 Sep 7 '12 at 3:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.