Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A friend of mine had Windows 7 and Windows XP running in his Sony Vaio. I replaced Windows XP with Ubuntu 10.10. After that the laptop directly boots into Ubuntu. Even the grub menu does not appear during startup. I tried sudo update-grub, sudo update-burg but windows was not recognized.

How can I solve this issue?

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted
  • To restore the Windows 7 bootloader, you must first boot off your 7 installation DVD.
  • When you get to the Regional settings, select your Location/Keyboard setting then click next. On the next page you must click on Repair your computer.
  • On the next page, if it finds your Windows Vista/7 installation, make sure it is UNSELECTED before clicking next.Then click on Command prompt.
  • From there, type in the folowing,

    bootrec.exe /fixboot

    bootrec.exe /fixmbr

  • Now close the two windows and click Restart.

Note:

share|improve this answer
add comment

Please read through the following link. Hope the 4 & 5 steps can help you.

This is also a very helpful link.

I think the same problem is being discussed in the following thread
The guy who posted seemed to have got the same problem and has rectified it.

Thanks,
Sen

share|improve this answer
    
I actually don't want to reinstall windows...it takes lot of time to install additional software... –  Chethan S. Dec 22 '10 at 9:07
    
@chethan: If Windows does not appear in the boot menu, I think you will need to edit /boot/grub/menu.lst.. Please try that.. –  Sen Dec 22 '10 at 9:13
    
<superuser.com/questions/112678/…; Another link where a similar problem is being discussed –  Sen Dec 22 '10 at 9:28
    
Actually the guide will work only for grub versions < 2.0. From karmic onwards, grub 2.0 is the default. –  apoorv020 Dec 22 '10 at 10:40
add comment

You should check your grub configuration to see whether the timeout option has been disabled or something.

For old grub versions, see this link. For newer versions, see this link.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.