Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Matlab version 2012. I know there are many threads about this, suggesting to chmod +x the following files (if you are in installation directory):

sys/java/jre/glnx86/jre/bin/java
sys/java/jre/glnxa64/jre/bin/java

I also chmodded the install file in root of installation directory. However, after running sudo ./install I still get:

Preparing installation files ...
Installing ...
./install: 1: eval: /tmp/mathworks_4880/sys/java/jre/glnxa64/jre/bin/java: Permission denied
Finished

How is this possible? :)

share|improve this question
    
If you have extracted the iso then you get this error. Try to mount it. Everything works well after that. (For R2013a Release) –  ester Jan 15 at 19:06
add comment

7 Answers 7

Installing Matlab (which is 32-bit) on 64-bit Ubuntu causes this problem. You can try this command and proceed like normal again.

ln -s YOURMATLABFOLDER/sys/java/jre/glnx86 YOURMATLABFOLDER/sys/java/jre/glnxa64
share|improve this answer
    
This didn't seem to help. See output. –  Primož Kralj Sep 6 '12 at 17:58
    
Then I can't help you I'm afraid. This was the suggestion I got from Mathworks support. Didn't really work for me either. Luckily for me I have to run dual boot on this computer, due to other heavy applications that run under windows only. –  Erro Sep 10 '12 at 9:02
    
Still, thank you. –  Primož Kralj Sep 10 '12 at 19:41
add comment
up vote 0 down vote accepted

I've found the answer, no matter how weird it is. The problem was 64bit OS. When I tried with 32bit, Matlab installation worked and every other app I had previously trouble installing. So now I stick to 32bit.

share|improve this answer
add comment

Even at your 64bit system, the installation might as well work out coz i have just successfully installed Matlab2012a in mine... here's what i did.. :

1.in the /matlab-install-files/sys/java/jre/glnx86/jre/bin/java ,i did

 sudo chmod +x ./java

2.within the installation directory:

 sudo chmod +x ./install

3.finally, install by:

 ./install 

or

 sudo ./install
share|improve this answer
add comment

I did the following on my 64-bit Ubuntu and it worked.

chmod +x <MATLAB_DIRECTORY>/java/jre/glnx86/jre/bin/java

<MATLAB_DIRECTORY> is the directory where you have all the MATLAB installation files in.

Then, in the install script (<MATLAB_DIRECTORY>/install), change line 441 from

JRE_LOC=

to

JRE_LOC="<MATLAB_DIRECTORY>/java/jre/glnx86/jre/"

And then run ./install in the <MATLAB_DIRECTORY>

share|improve this answer
add comment

You may try this for the 64 bit version if doing chmod on java file doesn't work:

-Make a tmp directory in your home directory
-now run install using "./install -tmpdir <path to the above made tmp directory>"
share|improve this answer
add comment

In many cases, the file system on which the install disk is mounted, is such that the file's permission cannot be changed to +x. In such cases, open the install script, go to somewhere around line which does echo Installing.... and eval $java_cmd. Just put a read between these two lines. Then, in another tab, go to /tmp/mathworks_<some-4-digit-random-number>/sys/java/jre/glnxa64/jre/bin/ and do chmod +x java. Then in the previous tab, press enter.

share|improve this answer
add comment

I assumed the appropriate symbolic link is, instead, something like

ln -s MATLABLOCATION/sys/java/jre/glnxa64 MATLABLOCATION/sys/java/jre/glnx86

If you want to link the missing x86 JRE folder with the existant x64 of your install location.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  guntbert Jun 1 at 16:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.