Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to enable alsa on different prefix than default through winetricks. More specifically, the prefix that has Rosetta Stone on it, as it cannot see my microphone.

When I open winetricks, it only lets me select default. I tried anyway, on default, and it did not resolve the issue.

I saw some answers online, through the terminal, but that didn't work either. Maybe I have the syntax wrong?

steve@stevelap:~$ WINEPREFIX=~/.PlayOnLinux/wineprefix/Rosetta sh winetricks alsa
sh: 0: Can't open winetricks
steve@stevelap:~$ sudo WINEPREFIX=~/.PlayOnLinux/wineprefix/Rosetta sh winetricks alsa
[sudo] password for steve: 
sh: 0: Can't open winetricks

Could anyone please offer assistance? Thanks!

share|improve this question
Curious! When I double-checked the Audio tab for that prefix's winecfg, the driver says winealsa.drv. The problem must lie elsewhere, this is unfortunate. I will keep looking. – Steve Sep 6 '12 at 11:34
up vote 3 down vote accepted

I found the answer to my question.

The following worked for me:

WINEPREFIX=/home/steve/.PlayOnLinux/wineprefix/Rosetta winetricks

It launched the GUI, and when I selected default then clicked browse files, it brought me to the Rosetta prefix to confirm.

share|improve this answer
(Although still no luck getting microphone to work in Rosetta Stone. D'oh!) – Steve Sep 6 '12 at 13:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.