Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu Unity is fast in my computer running multiple windows etc., but after an update, Software Center suddenly shows and when a script stops running (usually when I'm on FB), it suddenly slows down and sometimes freezes.

How do I prevent the script to suddenly stop?
How do I choose a tag, its so difficult to put one?

share|improve this question
    
Did you try turning off Automatic Updates? –  Mitch Sep 6 '12 at 4:24
    
Updating sometimes noticeably affects your disk i/o but I wonder if your symptoms are caused by Flash running on Facebook pages? If this is correct try Chrome, it has the least bad Flash support in Linux. –  Tom Brossman Sep 6 '12 at 7:19
    
how do i turn off automatic updates? –  juan Sep 7 '12 at 3:10

2 Answers 2

Usually when the update program is running it will download all the new sources and process them which takes a bit of processing power to do, and then if you click update it will run through each one and install them... It's only natural that things may slow down during this process...

share|improve this answer

If this is caused by I/O waits because of lots of dirty pages being written out to disk, you may like to try a different I/O scheduler to see if this helps. Try the "deadline" I/O scheduler and see if it makes a difference, for example for block device /dev/sda, use:

 echo "deadline" | sudo tee  /sys/block/sda/queue/scheduler
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.