Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried doing Ctrl+Alt+F1 but I cannot login since every time I type at the password field no characters are being input or I just got the wrong username password.

How do I solve this?

share|improve this question
I got this message while installing Ubuntu Server x32 in Oracle VM VirtualBox. – John Scott Jun 7 '14 at 1:40

I've checked in French Ubuntu forums, unfortunately to no avail for me, and for some this did work:

You need to verify that your /home/$USER/.Xauthority file is not owned by root.

You can simply check that with ls -ld .Xauthority (assuming you are in the home directory) and revert it back with

sudo chown $SUDO_USER .Xauthority

Let me know if that helped. I had to reinstall from scratch.

share|improve this answer

I got the problem after I removed GDM. (Running 12.04 with Openbox.) I solved it by pressing Ctrl+Alt+F2 to another console and reinstall it.

Should it realy be $SUDO_USER or am I supposed to replace it with my username for example? Well, it didn't work anyway. On the other hand, I didn't try very hard.

share|improve this answer

Use this command works just fine IMHO I had similar problem now its fixed.

sudo chown username:username /home/username/.Xauthority

Just put your username in place of username in the command.

share|improve this answer

At login: Ctrl+Alt+F1

sudo chown -R $USER:$USER $HOME


Enter your password and login. Worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.