Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu with Fluxbox and I would like to video chat on Skype. However, Skype doesn't recognize my webcam.

  1. Ubuntu 12.04
  2. Skype 4.0.0.8
  3. libv4l-0 and libgstreamer0.10 are installed
  4. luvcview provides an awesome output from my webcam, so it's working, just not in skype (which means it works in cheese as well)
  5. Reinstalling skype with gdebi didn't solve the problem.
  6. Reinstalling Ubuntu with Fluxbox minimal install from scratch doesn't solve the problem either.

Now, my question: Does anyone know what Skype needs for webcam recognition in Fluxbox or under Fluxbox?

share|improve this question
add comment

4 Answers

You must run skype with v4l. To do this type:

Exec=bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'

share|improve this answer
    
Okay, this looks like something I would add to fluxbox's startup file. Does this start skype on boot? Because that's not exactly what I want. What exactly does it do anyway? I mean, I'm glad about your help but I don't want to add something to my config files without knowing what it does. –  shlomo Sep 5 '12 at 13:24
    
Well, for all those trying to solve the same problem: This solution only works in ONEIRIC 32bit. More info, follow this one: community.skype.com/t5/Linux/… –  shlomo Sep 12 '12 at 15:47
add comment

I'd suggest to check the packages that were removed along with the KDE, some of them should be responsible for controlling the webcam drivers.

Additionally, check if your controllers are recognized by skype (using skype preferences).

share|improve this answer
    
Thanks for the help :) I will check for the removed packages. I guess I can find this in /var/log/apt. About the controllers: Would that be the devices list in the skype video preferences? If that's the case then skype doesn't recognize my controllers as it says "No device found". –  shlomo Sep 5 '12 at 13:20
    
@shlomo I remember that one I had the same problem. I believe that was solved once cheese was installed. That worked with Gnome! –  Dox Sep 5 '12 at 13:30
add comment

I've found another more recent forum entry addressing a similar issue. It was solved by preloading the libv4l.so. However, that didn't help for me. However, here's the link: http://forums.linuxmint.com/viewtopic.php?f=47&t=110742&p=621448

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Peachy Sep 14 '12 at 2:38
add comment

I was able to find a workaround. Installing gnome-shell solved the problem in fluxbox as well. I don't know what exactly was missing but at least I can use my webcam now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.