Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's aboot time I asked this one. Firefox thinks I'm Canadian.

I've got absolutely nothing against Canadians and their spelling is a lot better than Americans' but I don't spell specialised with a z. There are other, similar issues where I'm writing something and suddenly the dunce-squiggle pops up.

Anyway... How on earth does one set the default language? Can I remove English (Canada) completely?


Some clarifications as to why some of these answers aren't right for me, but might be right for somebody else:

  • Select another dictionary in Firefox by right clicking a textarea — This didn't hold between sessions. I would quit Firefox sipping my cup of tea, start it back up and be halfway through O Canada.

  • Remove the Canadian dictionary from Firefox — Simple: I didn't have it installed. The only dictionary language pack I had installed in Firefox is GB.

In my case I had somehow installed system-wide dictionary packages for en_CA and en_ZA. I've still no idea why or even how these kept replacing the Firefox default because I also have a system-wide en_GB dictionary package. Very odd. Package.

share|improve this question
1  
This could help: askubuntu.com/questions/50049/… –  rearlight Sep 5 '12 at 11:02
3  
+1 for the correct use of 'aboot'. –  Tom Brossman Sep 5 '12 at 11:04
    
@TomBrossman What's the wrong way? "I went sailing on aboot"? "On my foot is aboot"? –  Oli Sep 5 '12 at 11:04
    
@rearlight That's currently how I change back to Real English, yeah - but it doesn't stick. If I close Firefox and start it back up, I'm back in Canada. –  Oli Sep 5 '12 at 11:06
    
You, Dan, and Mitch have all made reference to accessing Language options by right-clicking a text area. I don't have this on my right-click menu (and I have FF prefs set to check spelling). Am I missing something basic? I can post this as a new question if necessary. –  Tom Brossman Sep 5 '12 at 11:46

4 Answers 4

up vote 9 down vote accepted

Firefox seems to use myspell/hunspell and listing /usr/share/myspell/dicts/ shows me the dictionaries that I'm given options to use:

$ ls -1 /usr/share/myspell/dicts/*.dic
/usr/share/myspell/dicts/en_CA.dic 
/usr/share/myspell/dicts/en_GB.dic
/usr/share/myspell/dicts/en_ZA.dic
...

Search for the dictionary filename in installed packages:

$ dpkg -S /usr/share/myspell/dicts/en_CA.dic
hunspell-en-ca: /usr/share/myspell/dicts/en_CA.dic

So with the Canadian language package name, the fix is to remove it:

sudo apt-get remove hunspell-en-ca
share|improve this answer
3  
wow you to do stuff the hard way :p –  Dan Sep 5 '12 at 11:17
2  
sudo apt-get remove myspell-en-au myspell-en-gb myspell-en-za hunspell-en-ca && sudo apt-get install myspell-en-us Whew! Thank you! No offense my good Brits but this had been driving me nuts for two years now, cheers! –  Insperatus Jan 17 '13 at 8:31

A simple answer is saying that a language pack is an Add-on.

Go to Tools -> Add-ons.
If you are using Ubuntu 12.04 or newer, you can use Dash to search in your menu; Tap Alt, and start typing Add-ons.

After you open the Add-ons manager, click on the Languages tab in left menu. There, you can disable any language.

After adding a language, just right click on any text area, or input field (By default input fields have spell checking disabled, so you will need to enable it before proceeding to the next step.).

Choose Language from the context menu, and select the language you want, and this will become your default language until you change it again.

P.S. Clicking on "Add language" in the context menu, will take you to a page which contains a listing of language dictionary packs that links to their corresponding add-ons.

share|improve this answer
    
Previous comment was incorrect :) Either way, I didn't have a Canadian language pack installed and I did have the British one installed - it was getting it from MySpell/HunSpell –  Oli Sep 5 '12 at 11:21

Right click on a text area, make sure that Check Spelling in checked, and choose the right dictionary.

enter image description here

Then go to the add-on page click on extensions, and either disable or remove the one that you don't want.

enter image description here

share|improve this answer
1  
I don't have that same right-click context menu, is it Windows-only? The 'Languages' option isn't there. –  Tom Brossman Sep 5 '12 at 11:32
    
Make sure that Check Spelling in checked, and those options will appear. –  Mitch Sep 5 '12 at 11:35
    
It is, in Preferences/Advanced/General/'Check my spelling as I type' –  Tom Brossman Sep 5 '12 at 11:37
    
The thing is, that since Firefox is installed with apt-get the default language packs that are installed, are also installed with apt-get and you cannot remove them from Firefox. You can only disable them with Firefox. If you need to remove them, it has to be done through apt-get. Only dictionaries added through AMO can be installed from within Firefox. –  Dan Sep 5 '12 at 16:52
    
@Oli Did this work for you? –  Mitch Sep 8 '12 at 15:00

Insperatus's comment deserves to be a full answer. I've had this problem not only with Canadian spelling, but sometimes Firefox would use UK or Australian spelling. On Ubuntu Linux, removing the dictionaries from the system for non-US English fixes this problem.

sudo apt-get remove myspell-en-au myspell-en-gb myspell-en-za hunspell-en-ca && sudo apt-get install myspell-en-us

Before:

firefox spelling language before removal

After:

firefox spelling language after removal

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.