Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed ubuntu server edition in order to create a home network. But I am not able to find IP of the machine through ifconfig (showing only localhost). Then I tried

 lspci | grep -i ethernet

output:

09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)

lshw -C Network

Then output was *-network DISABLED

share|improve this question
    
Did you check your BIOS to see if its disabled? –  Mitch Sep 5 '12 at 10:30
    
how to check that. I do not have any "network" tab in BIOS menu. –  Subhransu Sep 5 '12 at 11:06
    
What brand and Model system do you have? –  Mitch Sep 6 '12 at 7:20
    
My PC's motherboard is ASUS. And Bios is of AMI(american Megatrend inc) –  Subhransu Sep 6 '12 at 16:20
1  
If you have a DHCP server running (like, on your router), just try setting it up temporarily: sudo ifconfig eth0 up; sudo dhclient etc.. sometimes it just needs a kick in the pants! –  Grizly Nov 5 '12 at 3:48

1 Answer 1

up vote 1 down vote accepted

sudo less /var/log/installer/syslog

and check for eth0 or eth1 etc and see if it rejected your network card.

You didn't notice any problems during install though? It connected to the net and downloaded stuff alright?

If so, then try /var/log/dmesg

share|improve this answer
    
During installation the installer was not able to find dhcp server. So I skipped the network setting. Dose that causing the problem. And also its a server addition so it do not have gui and also its not able to recognize wired connection. –  Subhransu Sep 5 '12 at 11:09
    
It might, I've never done that though. Did you check the logs? –  Adam Sep 5 '12 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.