Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a convertible thinkpad (x201t) and magick-rotation to rotate the screen by 90 degrees in tablet mode. Therefore after rotation the screen's width is only 800 points (the ordinary resolution is 1200x800).

The Dash does not adapt to this new state and therefore if I click on it, it is oversized and I cannot reach the applications/files/buttons on its side.

Is there a way to tell the Dash that it should only ever use a width of 800 pixels, or any other solution to automatically adapt its size when rotating?

share|improve this question
add comment

2 Answers 2

Here's a solution I think might help. There is a program called "MyUnity" and it is designed to let you customize Unity more than you would be able to with the default settings manager. There is a setting in that program to change the dash size. From what I have read online, there is a setting that maximizes the dash to whatever screen size you have. There is also a setting that does not ever maximize the dash.

You can install it with the following terminal command:

sudo apt-get install myunity

Once MyUnity is installed, open it and click the "dash" tab at the top of the window. The last option is for dash size. "Automatic" is obviously the default setting, and I think that is what is causing the current undesirable behavior for you. "Netbook" is the one that maximizes the dash to whatever screen size you are using, and "Desktop" is the setting that makes the dash a fixed size that is smaller than your screen size.

Please let me know if it solved your problem.

share|improve this answer
add comment

nicktrip suggested MyUnity which will probably work; an alternative is Ubuntu Tweak. The dash size menu can be found under Tweaks > Desktop > Unity. No differences it seems, it also has three options: automatic, desktop and netbook.

Ubuntu Tweak

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.