Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP Compaq 2510p laptop running ubuntu 12.04 LTS. ubuntu reports that wireless is disabled by means of a hardware switch. There is a 'soft-key' button on the laptop to control the physical wireless hardware but this does not respond. There is no other button, slider, (fn)+ combination to control the physical wireless hardware. There is no BIOS function to disable wireless (and on XP - previous OS - wireless functioned fine).

mike@ubuntu:~$ rfkill list all
0: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Running rfkill unblock all doesn't change things and I can see no way to change use from 0: to 1: (if that's even possible - or desirable - in the first place).

I have checked for additional drivers and the Broadcom proprietary wireless driver is already installed and has a green light.

Essentially, I believe I need to make the HP 'soft-keys' work - or at least the wireless card toggle.

Advice gratefully received.

share|improve this question
add comment

3 Answers

I don't know if it's applicable to your situation but I had pretty much the same problem with my ProBook 6550b.

You just need to turn on the wireless while you're at the login screen. Because for some reason you cannot turn it on again if it was turned off before the login

share|improve this answer
add comment

I just noticed the same problem today with my 2510p. Solution: restore the BIOS defaults.

share|improve this answer
    
Perhaps your answer would be improved by giving instructions (or at least linking to them) for restoring the BIOS? –  theJollySin Jan 10 '13 at 22:39
add comment

This has worked for me with a Broadcom card. Uninstall the Broadcom driver, then:

sudo apt-get install firmware-b43legacy-installer

Hope that helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.