Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

keyring password prompt

(In my case this message never appeared before installing Ubuntu One - see this question). Can I use Ubuntu One and avoid being prompted each time like this? I use Lubuntu 12.04.

Edit: After exchanging comments I add the supplementary info:

  1. I am asked for password and to select session if I log out and in (auto-login is NOT set).
  2. Ubuntu One is installed but set NOT to start with session.
  3. Keyring appears nonetheless.
  4. Before installing Ubuntu One this didn't happen.

Also, following the advice of con-f-use, I have entered ps -A | grep -i [u]buntu in terminal, and got 2346 ? 00:00:01 ubuntuone-syncd, which means that ubuntuone is running when it was not supposed to.

share|improve this question

marked as duplicate by user68186, Nathan Osman, aquaherd, belacqua, Eric Carvalho May 16 '13 at 0:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
For that, see my comment in the other question. Now on topic and to recap: You don't have auto-login enabled, when you reboot your Lubuntu you are prompted for your Lubuntu-password before you can do anything. After you installed Ubuntu One the keyring dialogue keeps popping up eventhough Ubuntu One is not started automatically. Is that correct? –  con-f-use Sep 5 '12 at 10:29
    
exactly. added that info in question –  cipricus Sep 5 '12 at 10:40

3 Answers 3

The keyring can store passwords and encryption keys for you. They are protected with your login password and stored safely via encryption. It's like putting all your keys in a safe that just has one key. Every time you use an application (like e.g. Ubuntu One) for which you have stored a password for in the key ring, the key ring enters it for you. Beside the comfort factor that helps to counteract key-loggers and the like, as they need physical access to your key-ring data and your account password.

Normally, if you don't have auto-login activated, the keyring is unlocked, when you login to L/Uubuntu using your account's regular password. Since you seem to have enabled auto-login on start-up (just a guess), the keyring has to be unlocked manually with your accounts password (once on first use for each session) .

What you can try:

Auto unlock option

Usually there is an option to "Automatically unlock this keyring when I log in":

key ring auto unlock

Unset keyring password

For obvious reasons this is very insecure. If no one but you has physical access to your computer this could be the way to go.

In Lubuntu you might not have already installed "Passwords and Keys" (seahorse). To install:

sudo apt-get install seahorse

or https://apps.ubuntu.com/cat/applications/seahorse/

  1. Open the "Passwords and Keys" (in Menu/Preferences, or Alt-F2: seahorse)
  2. On the appropriate folder corresponding to your user account click right
  3. In the popup menu click "Change Passwords"
  4. In the resulting dialogue enter your old account password and leave the new password blank

Sudoers file

You can try to edit your /etc/sudoers file like this:

  1. Run sudo VISUAL=/usr/bin/gedit visudo
  2. At the bottom of this file add the line

    cipricus ALL=(ALL) NOPASSWD: /usr/bin/ubuntuone
    

    Assuming "cipricus" is your account's username under Lubuntu.

  3. Make sure everything is correct, close geidt, than run Run sudo -K to update your sudoers session.
share|improve this answer
    
i am in lubuntu, not unity. i have settings to ask me for password before login (when selecting session). once in my session i do not understand why keyring appears. ubuntu-one is set not to start with the session. the message appears nonetheless only because i installed ubuntu-one. –  cipricus Sep 5 '12 at 10:16
    
Hmm... should've said so before. This seems to be a bug then. Have you considered reporting a bug? –  con-f-use Sep 5 '12 at 10:23
    
i'll do that. but what should i say? that: "after entering my pass before session login the normal way i should not be asked again for pass by the keyring, and that is what happens after installing ubuntuone". is this the bug? –  cipricus Sep 5 '12 at 10:32
1  
Either the bug is, that after installing Ubuntu One you are prompted to unlock the key ring, although Ubuntu One is not running or that the keyring should automatically unlock itself when you log in to Lubuntu and never ask you again for a password as long as the session is running. To know which of the two, you have to confirm that Ubuntu One is not running in the background, e.g. by ps -A | grep -i ubunt[u]. If you choose to report a bug, please include a link to the launchpad-bug here for others that encounter your problem. –  con-f-use Sep 5 '12 at 10:35
    
running ps -A | grep -i ubunt[u] i get 2346 ? 00:00:01 ubuntuone-syncd. does that mean that it is running? i guess so (although ubuntuone is not visible in task manager). that's the bug then? –  cipricus Sep 5 '12 at 10:53
up vote 4 down vote accepted

For "What is Keyring" and how do you generally get rid of the Dialog, you can read con-f-use's answer.

Ubuntu One specific

I have uninstalled Ubuntu One in Lubuntu Software Center and rebooted. After that ps -A | grep -i [u]buntuone would show that Ubuntu One is still running. Checking the Synaptic Manager, a lot of the related packages were still there. After uninstalling all of them and after logout/login finally no keyring popped up.

share|improve this answer
1  
So the whole problem was, that the sync daemon was still running in the background asking for access to your keyring? That could still be a but, since the keyring is supposed to be unlocked by the time you start a session. But if purging everything Ubuntu One related helped you, I'm glad and it's probably not worth looking further into the matter. –  con-f-use Sep 5 '12 at 14:20

Try logging into Ubuntu one and un-tick box that says start at login. It worked for me :)

share|improve this answer
    
Where is that box? –  Eliah Kagan Mar 21 '13 at 12:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.