Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Getting problems on the Ubuntu 11.04 for openconnect... the failure after connecting says:

Got CONNECT response: HTTP/1.1 200 OK
CSTP connected. DPD 30, Keepalive 20
Connected tun0 as 172.21.246.21, using SSL
DTLS handshake failed: 2

I thought it is a kernel fault so I updated to 12.04 which didn't change the message. It could be that the vpnc-script has the problem. Is there any workaround for this issue ?

I already got the vpnc package and downloaded the /etc/vpnc/vpnc-script

share|improve this question
    
Did you test whether the connection actually works? What vpnc-script are you using (i had to install the vpnc package to get /etc/vpnc/vpnc-script)? –  daniel kullmann Sep 5 '12 at 7:40

3 Answers 3

Is this bug your problem? I ran into this and ended up doing a distribution upgrade to 12.10 to get passed it...

Can’t connect to VPN from GNOME Shell

It's been a while since this happened and I don't entirely recall what I ran into, but your problem seems very familiar to me.

share|improve this answer

This seems to be a workaround. I never tried it though.

The LKML thread suggests replacing line 119 in vpnc-script with Code:

sed 's/cache//;s/metric \?[0-9]\+ [0-9]\+//g;s/hoplimit[0-9]\+//g;s/ipid 0x....//g'

Try your luck and if it works. Post the steps you followed as a answer for the others in the community

share|improve this answer
    
The link doesn't seem to apply to the OP's problem at all (different VPN client, different error message). Why do you think it will solve his problems? –  daniel kullmann Sep 5 '12 at 8:07
    
unfortunately in line 119 is an if clause sth. like if [ -r /etc/openwrt_release ] && [ -n "$OPENWRT_INTERFACE" ]; then . /etc/functions.sh I put it above otherwise doesnt make sense... but didn't work.... do u know which date the thread is.... I guess is an old one and the scriptline has already been changed.... –  Fendrix Sep 5 '12 at 8:23

It doesn't have any relation to the kernel. The last line says DTLS handshake procedure has failed. So I think you need to turn on verbose logs of your client and see why handshake fails. The problem comes from TLS/SSL library.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.