Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install openflow in Ubuntu, but I encounter a problem when installing regression suite. I follow the instruction from openflow website with the below lines

To update the OF_ROOT environment variable for your setup:

cd ~/   
cp <openflow-dir>/regress/scripts/env_vars .  
vim env_vars

but when I run vim env_vars, I get a vim: command not found error. Why?

share|improve this question

try installing vim:

sudo apt-get install vim

or you can use a different text editor, like nano, which may be easier to use:

nano env_vars

share|improve this answer
This is needed because vim is not installed on Ubuntu by default. – Steve Kroon Sep 5 '12 at 8:01
Thanks!! I got it worked :) – user87313 Sep 7 '12 at 3:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.