Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just tried installing software called Teamviewer. It said there was some kind of error with unresolved dependancies. Then I realized I was trying to install the 32 bit version, but I needed to install the 64 bit version. So I tried that, and I got an error saying that Ubuntu needed to do a partial upgrade.

I thought that was weird, so I just wanted to abandon installing anything and get out of this. I exited all programs and rebooted, and now I can't get back into Ubuntu. After the GRUB screen I get a black screen and no login options.

If I boot into recovery, I get the following screen: enter image description here

I booted up a live CD of 12.04 to see if that could help, but it seems the only option is to completely reinstall Ubuntu.

Can I repair this in any way, or is my only option to make a fresh install?

share|improve this question
This appears to be a duplicate question:… – hnasarat Sep 5 '12 at 4:30
@hnasarat It isn't a duplicate because he isn't booting to a "black screen". – jokerdino Sep 5 '12 at 6:01
up vote 3 down vote accepted

Proceed with extreme caution. Having sufficient backups is encouraged at all times as you are just one step away from having to reinstall your entire system. Also, I don't claim responsibility for any possible disastrous outcomes. Good luck and all the best.

A not so great idea at fixing your problem.

You could try chrooting from a LiveCD of the same architecture and try and fix the broken packages.

Note: chrooting will fail if it is not of the same architecture. For example, you can only use a 64-bit LiveCD if your partition is also 64-bit. Or else, chrooting will fail midway. You can check your architecture with the command uname -m.

Run sudo fdisk -l and take note of the partition where your Ubuntu install is installed.

Create a directory in /mnt for mounting the partition later on:

sudo mkdir /mnt/1

Assuming the file system of the partition is of the type ext4, mount the partition at /mnt/1.

sudo mount -t ext4 /dev/sda5 /mnt/1

If you entered a wrong filesystem type, you will get an error similar to this:

$ sudo mount -t ext3 /dev/sda5 /mnt/1
mount: wrong fs type, bad option, bad superblock on /dev/sda10,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

If you are not sure of the filesystem, mount the partition in your File manager and then run df -T. Take note of the filesystem type and then unmount and mount it with the correct filesystem type:

sudo umount /dev/sda5

Now that you have correctly mounted it, chroot it to the previously created directory at /mnt.

sudo chroot /mnt/1

If you get chroot: failed to run command /bin/bash no such file or directory, try copying /bin and /lib to /mnt/1 and try chrooting again.

sudo cp -r /bin /lib /mnt/1

Now that you have chrooted into the system, try fixing the broken package through apt-get update && apt-get upgrade. If there are any unresolved broken or unmet dependencies around, try to clean it up.

Hopefully, you now managed to resolve and remove any corrupt packages that might have previously stalled your boot process.

Any other extraordinary situations arising at this point of time demands its own question.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.