Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I fire up a GNOME-Terminal in 12.04 This is the sort of font I get:

Normal Font

I really like it and want to keep it. When I run Xmonad and fire up a GNOME-terminal I get this sort of font:

Xmonad Font

Why are they different, and more importantly, how can I change it so that I get the first font when I use Xmonad?

share|improve this question
add comment

3 Answers 3

Had exactly the same problem (with the same font), it seems your bottom screenshot uses "hintsfull" whilst the top one uses "hintslight" (which I prefer)

I corrected the problem by using the following ~/.Xresources

Xft.dpi: 96
Xft.lcdfilter: lcddefault
Xft.antialias: true
Xft.autohint: true
Xft.hinting: true
Xft.hintstyle: hintslight
Xft.rgba: rgb

For reference, I also use the following ~/.gtkrc-2.0

gtk-theme-name="Ambiance"
gtk-icon-theme-name="ubuntu-mono-dark"
gtk-font-name="Ubuntu 11"
gtk-cursor-theme-name="DMZ-White"
gtk-cursor-theme-size=24
gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=0
gtk-menu-images=0
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintslight"
gtk-xft-rgba="rgb"

Alternatively, you can also run Xmonad under Gnome (I this case, Gnome controls the AA and you don't need to mess with config files) as it is quite widely documented, but to me, it defeats a bit the purpose of having an ultra-light WM.

share|improve this answer
    
+1 Works like a charm! My config: Ubuntu 13.10 x86_64 xmonad 0.11 –  Sandeep Datta Apr 5 at 18:12
add comment

It looks to me like they're the same font, but with different hinting levels.

Did you indeed check that they're the same under the Terminal menu: Edit > Profile Preferences > General ?

This question seems similar: No anti-aliasing with Xmonad

Perhaps these posts would also be helpful: http://ubuntuforums.org/showthread.php?t=1349509

share|improve this answer
    
Yeah, they are the same under the gnome-terminal settings. The related posts didn't really yield a solution, unfortunately. –  oadams Sep 24 '12 at 9:47
add comment

This is not a tested answer, but I believe you can set it in ~/.fonts.conf, as this FreeBSD post shows (excerpt):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

    <!-- default quality settings -->
    <match target="font">
        <edit mode="assign" name="rgba">      <const>none</const>     </edit>
        <edit mode="assign" name="antialias"> <bool>true</bool>       </edit>
        <edit mode="assign" name="autohint">  <bool>true</bool>       </edit>
        <edit mode="assign" name="hinting">   <bool>true</bool>       </edit>
        <edit mode="assign" name="hintstyle"> <const>hintfull</const> </edit>
    </match>

    <!-- reduce ringing ==> requires freetype2 'WITH_LCD_FILTERING=yes' -->
    <match target="font">
        <edit mode="assign" name="lcdfilter"> <const>lcdlight</const> </edit>
    </match>

    <!-- disable autohinting for bold fonts -->
    <match target="font">
        <test compare="more" name="weight">   <const>medium</const> </test>
        <edit mode="assign"  name="autohint"> <bool>false</bool>    </edit>
    </match>

    <!-- disable autohinting for fonts that don't need it -->
    <match target="pattern" name="family">
        <test qual="any" name="family">
          <string>Andale Mono</string>
          <string>Arial</string>
          <string>Arial Black</string>
          <string>Comic Sans MS</string>
          <string>Courier New</string>
          <string>Georgia</string>
          <string>Impact</string>
          <string>Trebuchet MS</string>
          <string>Tahoma</string>
          <string>Times New Roman</string>
          <string>Verdana</string>
          <string>Webdings</string>
       </test>
       <edit mode="assign" name="hinting">  <bool>true</bool>  </edit>
       <edit mode="assign" name="autohint"> <bool>false</bool> </edit>
    </match>
</fontconfig>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.