Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I load GEdit, it is different from sudo GEdit. Normal GEdit gives me Gtk warnings in the console, and ithas a different look. When I install plugins on either version, it doesn't reflect on the other.

I tried removing gedit and reinstalling, but I get the exact setups (in other words, GEdit didn't actually go away when I removed it)

Any advice on how I can actually remove gedit and start over?

(I have tried sudo apt-get remove --purge gedit - no joy)

share|improve this question
up vote 7 down vote accepted

This is the same application, only with different settings. Applications store their settings in the user's home directory - when you start gedit from your user account, it uses settings from /home/yourusername/, when you start it as root, it uses settings from /root/.

This is a good thing, because if they used the same settings, applications would constantly have problem with permissions accessing files.

Also, removing (or even purging) a package only removes files which were installed by the package manager - program's settings in users' home directories are not removed, just as the documents you created with that program are not removed when you uninstall the program. This explains why re-installing gedit does not reset the settings to the initial state.

share|improve this answer

When you run gedit via sudo, it's actually running under the superuser's account. That's why plugins installed in normal gedit (your account) don't show on sudo gedit (running under another account).

Plugins are installed in your current user's .local/share/gedit/plugins/ directory. If you want them to be available globally, you can install them manually in /usr/share/gedit/plugins.

Also, the fact that they look different can potentially also be caused by different settings. I bet you have tweaked the settings under your account, but the superuser's account remains with the default configuration.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.