Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After my computer with ubuntu 12.04 has been idle for a short while, the screen will go blank, and even enter standby mode. I have tried this:

  1. System Settings -> Brightness and Lock -> Turn off screen... set to "Never"
  2. System Settings -> Power -> Suspend when... set to "Don't suspend"

This doesn't change anything.

How can I make sure that the screen will always remain on, forever?

share|improve this question
    
For me, installing xscreensaver did the trick: askubuntu.com/a/233055/104264 –  julesjulian Dec 27 '12 at 18:32

5 Answers 5

up vote 5 down vote accepted

Try opening a terminal with Ctrl+Alt+T and then enter the following:

gconftool-2 --type bool --set /apps/gnome-screensaver/idle_activation_enabled "false"
share|improve this answer

You can install the dconf-tools package and then run dconf-editor.

In dconf-editor, open up the "org" branch, then "gnome" then "desktop" then "screensaver" and you'll see the name-value pairs that set the various screensaver properties.

Change "idle-activation-enabled" to unchecked.

You could also uncheck "lock-enabled" while you're there to prevent it demanding your password when it's been idle too long.

However this might not work! It didn't work for me when I was trying and I can only assume that there is a bug somewhere in xfce4, which is the windows manager I installed on 12.04 instead of Unity. If you also suffer problems, the work-around is to use xset:

xset -dpms s off s noblank s 0 0 s noexpose

but that only lasts as long as your session.

You can use

xset -q

to see what the current settings are. It basically overrides the settings in /etc/X11/xorg.conf

You would have to put it into your .profile to re-apply it every session.

share|improve this answer

the only way I could stop the blank screen was to install xscreensaver which will then let you disable the gnomescreensaver daemon you can also remove the gnome-screensaver

then set xscreensaver to 'no screen saver'

to have xscreensaver start at log on open startup applications then add

name = xscreensaver

command = xscreensaver -nosplash

then save the settings ...

share|improve this answer

I tried the selected answer as well as:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Both did not solve the issue with me. I found this that ended up working. I'm sure there is some configuration option that would have solved the issue without me having to remove the package entirely, but I didn't feel like spending too much time on it.

sudo apt-get remove acpi-support acpid
share|improve this answer

managed to fix it by putting: "@xset s off" in my autostart file (after all other programs) and setting session idle timeout to its max value in dconf-editor

share|improve this answer
2  
Thanks for taking the time to answer the question. Would mind adding how to find the file and how to change the settings in the dconf-editor? –  MadMike Oct 17 at 9:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.