Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to follow the instructions for installing the android sdk found here:

After I've unpackaged and i run the android program under tools, I don't get all the options that I'm supposed to. The only 2 folders that show up are tools, and extras. Under tools, it only shows the "Android SDK Tools" with the status "Installed". Under the "extras" folder, I have nothing. I've made sure that my http: proxy settings are correct. And I've checked the logs. there are no errors. According to the android developer site, I'm supposed to install the SDK platform tools.

has anyone tried this on Ubuntu? I also checked and saw others were instructed to do an apt-get install ia32-libs but it failed for me. Besides which, I am running the 32bit OS... so I don't think i would need to install that... ??

I've also tried following the instructions found here:

But... I can't seem to add the personal archive nilarimogard without getting an error message.
when i attempt:

 sudo add-apt-repository ppa:nilarimogard/webupd8

I get the message:

Traceback (most recent call last):   File
"/usr/bin/add-apt-repository", line 125, in <module>
ppa_info = get_ppa_info_from_lp(user, ppa_name)   File "/usr/lib/python2.7/dist-packages/softwareproperties/", line 80,
in get_ppa_info_from_lp
curl.perform() pycurl.error: (7, "couldn't connect to host") root@jll:/home/me/Documents#

any suggestions?


share|improve this question

I just followed a previous post with a similar issue:… and it worked. I did get a the following warning:

Reading package lists... Done W: GPG error: oneiric Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 531EE72F4C9D234C

but it seems to get the java updates.

share|improve this answer

I can confirm that SDK installs on Ubuntu/Kubuntu without a problem, I did that more than once. You don't need any third-party PPAs for that.

Are you going to use Eclipse (you should)? If so, I suggest to skip this step and just start with installing ADT plugin as described here - it will download all necessary stuff in the process.

If you're behind a proxy see Troubleshooting section at the bottom of the page

share|improve this answer
I don't have Eclipse... I will check into it. I'm just new to kubuntu. But i don't actually plan on writing andriod stuff. i just want to install an emulator so i can test a website that I've built. Need to make sure it scales properly on a mobile device. Would you still recommend that i install the sdk and eclipse? – dot Sep 5 '12 at 12:51
I just followed a previous post with a similar issue:… and it worked. – dot Sep 5 '12 at 13:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.