Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04 with the XFCE desktop, all packages up to date.

I wanted to set up a keyboard layout for the Polish language (Polish uses the Roman alphabet, with a few additional characters like ą, ł, ż, etc). I went to the keyboard control panel, and under Polish I saw several options - all of them useless to me. One was for Kashubian. One was the obsolete QWERTZ layout. Several variations of DVORAK. And one for Russian - I don't even know what it was doing there. What was missing was the de-facto standard layout, known as "polski programisty" ("Polish programmer's").

  1. Is there a package that has the layout I want?

  2. If not, how do I create my own layout? And where do I send the patch?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Take the default Polish layout (the one with the name Polish, with no further specification). This is the programmers layout.

enter image description here

EDIT: Alternatively, you can always do setxkbmap -layout pl -variant basic or just setxkbmap -layout pl, but that will not be kept across sessions.

Both XFCE and the default Unity shell use the same layouts, just with different interfaces. I guess the reason that XDE uses a tree structure is that all the different variants of the Polish layout are defined in the same file, /usr/share/X11/xkb/symbols/pl. By the way, it is a simple text file; creating your own layout is not hard.

share|improve this answer
    
I just said that I don't have this layout. –  Mike Baranczak Sep 4 '12 at 21:52
    
Also, I'm using XFCE. This screenshot is obviously from something else. Maybe this is a problem with XFCE only? –  Mike Baranczak Sep 4 '12 at 21:54
1  
OK, I figured it out. The layout is there - it's just hiding in plain sight. In the control panel, where it's showing all the installed layouts, I don't see a list like you do - I see a tree. The root node of that tree says "Polish", so I assumed it was just a category, and couldn't be selected. But this is exactly what I have to select. –  Mike Baranczak Sep 4 '12 at 23:10
    
What is XDE? Do you mean XFCE? –  Anwar Shah Sep 20 '12 at 16:59
add comment

I was having the same problem after update to xbuntu 13.10.
Selecting Polish programmers keyboard is even more counter intuitive, as the selection dialog shows a tree instead of a list.
Here the way to select Polish programmers keyboard:

keyboard layout selection dialog

This dialog is accessible via Settings Manager > Keyboard > Layout > Add/Edit

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.