Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With a fresh 12.04 installation of Ubuntu, byobu's interpretation of the function keys seems to have changed. F3 and F4 will still change the active tab on the current session, but it changes it for all connections. Previously, if you have two active connections to the same user (same session) with User 1 on shell 0/tab 0 and User 2 on shell 0/tab 0, when User 2 pressed F3 , they would be changed to tab 1 while User 1 would remain on tab 0. With the latest version in 12.04, when User 2 presses F3, all connected users are moved to shell 1/tab 1. Is there any way to re-enable the old behavior? I have looked at the /etc/byobu directory and only found backend and socketdir files there. Toggling backend between tmux and screen did not seem to render any difference. Anyone know what, if any, configuration option exist to control this?

share|improve this question

1 Answer 1

12.04 byobu now defaults to tmux as a backend instead of screen.

So to get the byobu you are used to back, just type:

byobu-select-backend

and select the "screen" option instead of "tmux".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.