Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a HP compaq 8200 Elite CMT PC with an i7 processor and 16GB of ram. There are two hardisks on the pc one of which is 500GB and the other one is 1TB. I have a licensed copy of windows 32 bit on the 500GB which I cannot touch and I need to install a 64 bit ubuntu on the 1TB partition. The problem is when I install it normally with the grub and the ubuntu in 1TB hdd and I try to boot through it I get a grub error : no such partition. But windows does boot when I change the boot harddisk. I have tried things like boot repair,rescatux, re installing grub etc but none of them helped. I am also thinking there could be some bios issues.

Can anyone help fix this issue.

thanks in advance

share|improve this question

Re-install Ubuntu and while installing in partitioning screen check for where to install bootloader(on bottom of window). Set 1TB disk there and proceed with installation.

share|improve this answer
thanks for the help but I have already tried that.The error is when I try to boot from that hard disk. – bootstrap Sep 4 '12 at 10:54

See how to dual boot Linux/Ubuntu with Windows 7 under control of Windows boot manager - Dual boot Windows 7 and Linux/Unix

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.