Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The colours look "lacking" and ever slightly blueish and rather washed-out and lacking in dimension.

Graphics are ok - this page for example looks fine - but if I view something like a news site with high quality photos, the experience is not optimal and is noticeably inferior to Windows 7.

Oddly, when I install Ubuntu as a VM on VirtualBox in Windows, the colours look as I expect them to. It's only on my dual-boot version of Ubuntu that they look wrong (not Wubi, although a previous Wubi-based installation had the same problem).

Now, I have the proprietary ATI driver and I can use amdcccle to get the colours closer to what they should be, but I can't seem to do anything about colour depth.

The depth settings in Xorg are all 24. I tried changing all three mentions of 24 to 32 but was forced into safety mode. Fortunately, I remembered where I'd been tinkering and got the file set back to 24.

share|improve this question
    
Ok - some extra info. Xorg is showing 24 bits for 4, whereas Windows 7 is showing true color 32-bit i.e. 24 bits for 8. –  Simon Hoare Sep 4 '12 at 9:41
    
Xorg.conf has no reference to 4 or 8 bits. –  Simon Hoare Sep 4 '12 at 9:50
    
The Xorg log has [ 30.027] () fglrx(0): Depth 24, (--) framebuffer bpp 32 [ 30.027] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps) [ 30.027] (==) fglrx(0): Default visual is TrueColor [ 30.027] () fglrx(0): Option "DPMS" "true" [ 30.027] (==) fglrx(0): RGB weight 888 [ 30.027] (II) fglrx(0): Using 8 bits per RGB [ 30.027] (==) fglrx(0): Buffer Tiling is ON –  Simon Hoare Sep 4 '12 at 9:52
    
More info: the [calibrate] button is greyed out on Gnome color manager. On dispcalGUI, the update calibration box is untickable and the following options are greyed out: [calibrate] [calibrate & profile] [profile only]. –  Simon Hoare Sep 4 '12 at 10:16
    
Do I need an external device? –  Simon Hoare Sep 4 '12 at 10:23
show 1 more comment

1 Answer

maybe look at the monitor icc profiles. You can load them in gnome with gnome color manager or just using xcalib. Maybe in windows, some factory default icc profile is loaded for your monitor.

On my laptop, the colors look bluish without icc profile (factory standard seems to be 6500K temperature). I use color munki to calibrate the screen to get 4600K color temperature for the profile. Then colors look warmer....

Jos

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.