Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My netbook runs a dual OS(Windows7 & Ubuntu 12.04). After Ubuntu login screen appears, that’s it, it gets hanged, can't even move my cursor nor type my user name.

I had to turn off my system and boot again. Still its not sure that it won't freeze out at login screen again, but this is the temporary solution I have to get into Ubuntu.

This freezing at login screen doesn't happen every time, it happens randomly. It seems like I had to enter into Ubuntu purely based on my luck, which is quite irritating. I found many other types of login problem in Ubuntu when I googled, which were quite different from my case. So any1 kindly help me out.

share|improve this question

closed as too localized by Jorge Castro, Anwar Shah, stephenmyall, Mik, LnxSlck Oct 23 '12 at 13:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Which laptop is it? and what are the specs`? – Daniel Guldberg Aaes Sep 4 '12 at 7:27
Can you do Ctrl-Alt-F1 to switch to a text console? – January Sep 4 '12 at 8:48
@DanielGuldbergAaes Asus 1225b netbook, 4GB ram, 320GB HDD, AMD 64-bit, E450 processor with 1.66GHz speed. – user_rak Sep 4 '12 at 12:57
@January ctrl+alt+F1 doesn't solve my problem. There is no response when I do ctrl+alt+F1. – user_rak Sep 4 '12 at 13:06
I'm sorry, but I'm afraid I cannot help you. However, I will start a bounty in your name, maybe someone else would see what is going on. – January Sep 10 '12 at 8:22

I had exactly the same problem. Ctrl+Alt+F1 did not work, neither did Ctrl+Alt+Del. A complete freeze.

What seemed to work for me though was a reboot in the recovery mode which runs Unity 2D instead of 3D. I figured that it must have been due to the graphic card drivers. Since I was using GeForce ​GT ​540M, I installed Ironhide:

apt-add-repository ppa:mj-casalogic/ironhide
apt-get update
apt-get install ironhide

Then when configuring ironhide (ironhide-configure), I chose the last configuration from the bottom (apparently the most recent), for 12.04 LTS, and after reboot, it worked just as it used to, without any freezes.

Try it out yourself!

share|improve this answer
Kacper, have you seen this? :… – bob Sep 15 '12 at 15:05
@Kacper could the command apt-add-repository ppa:mj-casalogic/ironhide, be used for amd radeon 6320 graphics card or do i have to modify the command ? – user_rak Sep 16 '12 at 20:43
@rakesh: was that answer helpful in your case? Did you get to solve your problem? – January Sep 17 '12 at 10:58
@January i haven't tried this.Because, before i try, i want to know if this first command is applicable to my PC, because my pc uses a AMD radeon. when i googled, i found out that these commands are used by those who have Nvidia graphics card. So i am little afraid if this could corrupt my current drivers. if some1 can assure me that this command can be used to pc's with AMD radeon graphics card,then i can go ahead with this solution. Thats why i have raised a question to kacper. – user_rak Sep 17 '12 at 11:31
Ok, I was just asking "in any case" -- the bounty is due. – January Sep 17 '12 at 11:34

You can try login via command-line:

Type ctrl+alt+F1 at boot to switch to command-line login. Then your user name and password will be asked. Now you should have logged in successfully.
If you have some problems regarding this visit this link.

share|improve this answer
How about reading the discussion? The user reports that when the computer is hanging (which does not occur always), Ctrl-Alt-F1 does not work. – January Sep 10 '12 at 14:50
@January I am talking about boot screen or splash screen! – Pranit Bauva Sep 11 '12 at 9:47
yes, nonetheless the user stated clearly that "There is no response when I do ctrl+alt+F1." – January Sep 11 '12 at 10:29
@PranitBauva I don't get a command-line login when i press ctrl alt f1 during boot. It directly proceeds to the ubuntu login screen. – user_rak Sep 12 '12 at 9:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.