Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have OSX. My HD appears as two drives; one formatted for OSX, and the other FAT32 for everything. Note: I am a complete Terminal noob.

I followed the How to create a bootable USB stick on OS X page. I installed it to the Mac formatted partition, which I'm 95% sure was a mistake. I was thinking more in terms of free space than proper format.

Anyway, it doesn't boot, and I can't get the HD to appear when I plug it back into OSX. I have no idea how to undo what I did in Terminal. Any ideas?

share|improve this question
up vote 2 down vote accepted

If you did step #8 of those instructions (running dd command) then the first 700Mb of your disk (including the partition table, the bootloader and the beginning of the OSX partition) have been overridden by the data from the ISO file.

There's no undo and I guess restoring any data from the disk would require super-complex and time-consuming forensic methods, sorry.

Surely you have a backup of all your data, right?

There are tools called TestDisk and PhotoRec which might be able to restore the partition table or at least to recover some data from the disk. They work on MacOSX and claim to support HFS+ filesystem.

share|improve this answer
Oh dear. I've tried using Ubuntu many times in the past. It seems something always goes wrong. Kind of feels like deja vu. It was a 1TB drive, so if 700mb of stuff is overwritten then that's probably okay. But if it's all lost, oh dear. A lot of the stuff was the backup, misc files. I didn't know this would nuke the other partitions... :( – Jack Sep 4 '12 at 1:49
If you followed the instructions, that would write data straight to the disk, not into one of the partitions, which would override the partition table and the start of the first partition. If you somehow managed to direct dd to your OSX partition only, then the partition table would be intact and you should be able to see the second (fat32) partition. Do you see it? – Sergey Sep 4 '12 at 1:59
I also added links to the software which might help you to restore some data. – Sergey Sep 4 '12 at 2:03
I did direct it at the OSX partition. Diskutil listed 2 drives and I directed it at disk 1 as per the instructions. Thanks. – Jack Sep 4 '12 at 2:09
Those other two progs would only find the Ubuntu ISO. I tried a different app called Disk Drill. It's going to take 10 hours to scan, but it has already found some Final Cut Pro project. I used to work for an advertisement company, so most of the data is raw HD footage for my portfolio. But I don't really do that sort of stuff anymore so if's lost, oh well. – Jack Sep 4 '12 at 3:26

There are some software options to get back some of the files lost, but in general you are just going to have to start over with the HD to try it again. I'm not overly familiar with osX or I could be of more assistance. I'm not sure if OSX will recognize the ext2 3 or 4 partition types. Windows does not. It is possible your MAC is not set up to boot from usb devices. Check that first.

share|improve this answer
The disk comes up in my Disk Utility, but it won't boot or even mount like it normally does. It was 3 partitions: OSX/FAT32/Time Machine Backup. The data recovery tool seems to only be pulling up Ubuntu files... :( – Jack Sep 4 '12 at 2:04
It will pick up ubuntu files as well as other files. I'm not sure what program you are using for data recovery, but there are several options out there that work well even after formatting or deleting partitions. the Ubuntu live usb can not be put in any of those 3 types of partions it would create it's own in the size needed. Typically the rest of the space is left unallocated or as a separate partition. By following the instructions given you have reallocated the whole drive as a 700ish ext# (either 2 3 or 4) and more than likely the rest of the space is unallocated. – schonjones Sep 4 '12 at 3:22
That makes sense. It's just as you say. I'm using Disk Drill and it is currently recovering data from the unallocated part of the disk. Another partition exists and it is ~700MB. The program claims it can recover Mac drive stuff quite well depending on the circumstances. It said from the get go it can't recover the names of the files. So I have hundreds of past project .mov files with no names. It's all good. 8h 12m to go! – Jack Sep 4 '12 at 5:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.