Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having no luck using the microphone of my Dell XPS M1530 in Ubuntu 12.04. Applications such as vlc or skype that can take audio input receive silence (though no error or other diagnostic is generated by the application).

What I'm really interested in is: is there a general approach that works for debugging sound issues? Where do you start looking? And, most specifically: what are all the links in the chain between my voice and the sound recording application that can potentially be broken?

In case it might help in this particular case, here's the usual dump of information:

lspci:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

dmesg | grep -C 2 snd:

[   27.762737] [drm] Initialized nouveau 0.0.16 20090420 for 0000:01:00.0 on minor 0
[   27.764101] input: Dell WMI hotkeys as /devices/virtual/input/input10
[   27.798184] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[   27.798267] snd_hda_intel 0000:00:1b.0: irq 47 for MSI/MSI-X
[   27.798303] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
[   27.827935] cfg80211: World regulatory domain updated:
[   27.827940] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)

grep -r snd /etc/

/etc/apparmor.d/abstractions/audio:/dev/snd/*      rw,
/etc/default/alsa:#     "snd-cs46xx"  Stop sound processes and remove the snd-cs46xx module
/etc/modprobe.d/alsa-base.conf:install sound-slot-0 /sbin/modprobe snd-card-0
/etc/modprobe.d/alsa-base.conf:install sound-slot-1 /sbin/modprobe snd-card-1
/etc/modprobe.d/alsa-base.conf:install sound-slot-2 /sbin/modprobe snd-card-2
/etc/modprobe.d/alsa-base.conf:install sound-slot-3 /sbin/modprobe snd-card-3
/etc/modprobe.d/alsa-base.conf:install sound-slot-4 /sbin/modprobe snd-card-4
/etc/modprobe.d/alsa-base.conf:install sound-slot-5 /sbin/modprobe snd-card-5
/etc/modprobe.d/alsa-base.conf:install sound-slot-6 /sbin/modprobe snd-card-6
/etc/modprobe.d/alsa-base.conf:install sound-slot-7 /sbin/modprobe snd-card-7
/etc/modprobe.d/alsa-base.conf:install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
/etc/modprobe.d/alsa-base.conf:install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
/etc/modprobe.d/alsa-base.conf:install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
/etc/modprobe.d/alsa-base.conf:install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
/etc/modprobe.d/alsa-base.conf:install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
/etc/modprobe.d/alsa-base.conf:install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
/etc/modprobe.d/alsa-base.conf:install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
/etc/modprobe.d/alsa-base.conf:options snd-atiixp-modem index=-2
/etc/modprobe.d/alsa-base.conf:options snd-intel8x0m index=-2
/etc/modprobe.d/alsa-base.conf:options snd-via82xx-modem index=-2
/etc/modprobe.d/alsa-base.conf:options snd-usb-audio index=-2
/etc/modprobe.d/alsa-base.conf:options snd-usb-caiaq index=-2
/etc/modprobe.d/alsa-base.conf:options snd-usb-ua101 index=-2
/etc/modprobe.d/alsa-base.conf:options snd-usb-us122l index=-2
/etc/modprobe.d/alsa-base.conf:options snd-usb-usx2y index=-2
/etc/modprobe.d/alsa-base.conf:# Ubuntu #62691, enable MPU for snd-cmipci
/etc/modprobe.d/alsa-base.conf:options snd-cmipci mpu_port=0x330 fm_port=0x388
/etc/modprobe.d/alsa-base.conf:# Keep snd-pcsp from being loaded as first soundcard
/etc/modprobe.d/alsa-base.conf:options snd-pcsp index=-2
/etc/modprobe.d/alsa-base.conf:# Keep snd-usb-audio from beeing loaded as first soundcard
/etc/modprobe.d/alsa-base.conf:options snd-usb-audio index=-2
/etc/modprobe.d/blacklist-modem.conf:# blacklist snd-atiixp-modem
/etc/modprobe.d/blacklist-modem.conf:# blacklist snd-intel8x0m
/etc/modprobe.d/blacklist-modem.conf:# blacklist snd-via82xx-modem
/etc/modprobe.d/blacklist.conf:# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
/etc/modprobe.d/blacklist.conf:blacklist snd_intel8x0m
/etc/modprobe.d/blacklist.conf:blacklist snd_aw2
/etc/modprobe.d/blacklist.conf:blacklist snd_pcsp
share|improve this question
    
Try installing alsa-utils and launching alsamixer. Hit F4 to switch to the capture tab. What do you see? –  Relish Sep 4 '12 at 3:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.